summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-08-22 19:48:26 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-08-26 11:54:59 +0200
commit47d7b3038eb68724147adc2ccee288c16b674f63 (patch)
tree8e2f27ae6f9e0ee17e1494c70c20496510af5b48 /gnu/packages/admin.scm
parente7761186c3aacd36ae522e86e961d4f954be8794 (diff)
downloadpatches-47d7b3038eb68724147adc2ccee288c16b674f63.tar
patches-47d7b3038eb68724147adc2ccee288c16b674f63.tar.gz
gnu: fdupes: Update to 1.6.1.
* gnu/packages/admin.scm (fdupes): Update to 1.6.1. [source]: Update 'uri' template, add 'file-name' field. [arguments]: Set CC in make-flags.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 3ba59476fe..6215b9f6f0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2016 Peter Feigl <peter.feigl@nexoid.at>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Coypright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1244,21 +1245,23 @@ degradation and failure.")
(define-public fdupes
(package
(name "fdupes")
- (version "1.51")
+ (version "1.6.1")
(source
(origin
(method url-fetch)
(uri (string-append
- "https://github.com/adrianlopezroche/fdupes/archive/fdupes-"
+ "https://github.com/adrianlopezroche/fdupes/archive/v"
version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "11j96vxl9vg3jsnxqxskrv3gad6dh7hz2zpyc8n31xzyxka1c7kn"))))
+ "1sj9pa40pbz6xdwbxfwhdhkvhdf1xc5gvggk9mdq26c41gdnyswx"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-delete 'configure %standard-phases)
#:tests? #f ; no 'check' target
- #:make-flags (list (string-append "PREFIX="
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX="
(assoc-ref %outputs "out")))))
(home-page "https://github.com/adrianlopezroche/fdupes")
(synopsis "Identify duplicate files")