summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-04-15 23:54:18 +0200
committerLudovic Courtès <ludo@gnu.org>2014-04-15 23:55:15 +0200
commitfccf2fe06b2e2a3d6d57d0a8a86f370586a1f4b0 (patch)
tree843022d37a771bc1c73f57cc1197d99d68d42fe3 /gnu/packages/admin.scm
parent1da34f5ad5dff68b18d4d22002e48a61dc986881 (diff)
downloadpatches-fccf2fe06b2e2a3d6d57d0a8a86f370586a1f4b0.tar
patches-fccf2fe06b2e2a3d6d57d0a8a86f370586a1f4b0.tar.gz
gnu: Add Rot[t]log.
* gnu/packages/admin.scm (rottlog): New variable.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index bc654dfc75..418c094018 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -44,6 +44,7 @@
#:use-module (gnu packages flex)
#:use-module (gnu packages glib)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages texinfo)
#:use-module (gnu packages xorg))
(define-public dmd
@@ -576,3 +577,46 @@ by bandwidth they use.")
console window to allow commands to be interactively run on multiple servers
over ssh connections.")
(license gpl2+)))
+
+(define-public rottlog
+ (package
+ (name "rottlog")
+ (version "0.72.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/rottlog/rottlog-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0751mb9l2f0jrk3vj6q8ilanifd121dliwk0c34g8k0dlzsv3kd7"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "Makefile.in"
+ (("-o \\$\\{LOG_OWN\\} -g \\$\\{LOG_GROUP\\}")
+ ;; Don't try to chown root.
+ "")
+ (("mkdir -p \\$\\(ROTT_STATDIR\\)")
+ ;; Don't attempt to create /var/lib/rottlog.
+ "true")))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags (list (string-append "ROTT_ETCDIR="
+ (assoc-ref %outputs "out")
+ "/etc")
+ "--localstatedir=/var")
+ #:phases (alist-cons-after
+ 'install 'install-info
+ (lambda _
+ (zero? (system* "make" "install-info")))
+ %standard-phases)))
+ (native-inputs `(("texinfo" ,texinfo)
+ ("util-linux" ,util-linux))) ; for 'cal'
+ (home-page "http://www.gnu.org/software/rottlog/")
+ (synopsis "Log rotation and management")
+ (description
+ "GNU Rot[t]log is a program for managing log files. It is used to
+automatically rotate out log files when they have reached a given size or
+according to a given schedule. It can also be used to automatically compress
+and archive such logs. Rot[t]log will mail reports of its activity to the
+system administrator.")
+ (license gpl3+)))