summaryrefslogtreecommitdiff
path: root/gnu/packages/acl.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-11-04 10:36:36 -0400
committerLeo Famulari <leo@famulari.name>2017-11-04 10:47:39 -0400
commit2d433b5363fecba0d63caa1844c937dec4ccc23b (patch)
treeb2fb506c0f302dcbc3b7773aae2db75062ce16b6 /gnu/packages/acl.scm
parent75aea16fb0ef03424d8a366e29987aaba4c4cb64 (diff)
downloadpatches-2d433b5363fecba0d63caa1844c937dec4ccc23b.tar
patches-2d433b5363fecba0d63caa1844c937dec4ccc23b.tar.gz
gnu: acl: Enable tests.
* gnu/packages/acl.scm (acl)[arguments]: Enable tests. Add 'patch-tests' phase.
Diffstat (limited to 'gnu/packages/acl.scm')
-rw-r--r--gnu/packages/acl.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index 35bafc4c14..3540d40603 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -44,8 +44,7 @@
(patches (search-patches "acl-hurd-path-max.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; FIXME: Investigate test suite failures
- #:test-target "tests"
+ `(#:test-target "tests"
#:phases
(modify-phases %standard-phases
(add-after 'build 'patch-exec-bin-sh
@@ -53,6 +52,16 @@
(substitute* "test/run"
(("/bin/sh") (which "sh")))
#t))
+ (add-before 'check 'patch-tests
+ ;; The coreutils do not have an ACL bit to remove from their
+ ;; output, so the sed expression that removes the bit is disabled.
+ (substitute* "test/sbits-restore.test"
+ (("\\| sed.*'") ""))
+ ;; These tests require the existence of a user named "bin", but
+ ;; this user does not exist within Guix's build environment.
+ (for-each (lambda (file)
+ (delete-file (string-append "test/" file)))
+ '("setfacl-X.test" "cp.test" "misc.test")))
(replace 'install
(lambda _
(zero? (system* "make" "install" "install-lib" "install-dev")))))))