summaryrefslogtreecommitdiff
path: root/gnu/local.mk
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-04-28 14:15:28 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-05-05 16:13:53 +0200
commitf19cf27c2b9ff92e2c0fd931ef7fde39c376adaa (patch)
tree6d4805a1c7496e3e1e7c55084b84bd7ece348805 /gnu/local.mk
parentf8fd1157174fd523d36dcfa756c965a54c30d5ae (diff)
downloadpatches-f19cf27c2b9ff92e2c0fd931ef7fde39c376adaa.tar
patches-f19cf27c2b9ff92e2c0fd931ef7fde39c376adaa.tar.gz
image: Add a new API.
Raw disk-images and ISO9660 images are created in a Qemu virtual machine. This is quite fragile, very slow, and almost unusable without KVM. For all these reasons, add support for host image generation. This implies the use new image generation mechanisms. - Raw disk images: images of partitions are created using tools such as mke2fs and mkdosfs depending on the partition file-system type. The partition images are then assembled into a final image using genimage. - ISO9660 images: the ISO root directory is populated within the store. GNU xorriso is then called on that directory, in the exact same way as this is done in (gnu build vm) module. Those mechanisms are built upon the new (gnu image) module. * gnu/image.scm: New file. * gnu/system/image.scm: New file. * gnu/build/image: New file. * gnu/local.mk: Add them. * gnu/system/vm.scm (system-disk-image): Rename to system-disk-image-in-vm. * gnu/ci.scm (qemu-jobs): Adapt to new API. * gnu/tests/install.scm (run-install): Ditto. * guix/scripts/system.scm (system-derivation-for-action): Ditto.
Diffstat (limited to 'gnu/local.mk')
-rw-r--r--gnu/local.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index daf6bd0306..4e0521baa5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -62,6 +62,7 @@ GNU_SYSTEM_MODULES = \
%D%/bootloader/u-boot.scm \
%D%/bootloader/depthcharge.scm \
%D%/ci.scm \
+ %D%/image.scm \
%D%/packages.scm \
%D%/packages/abduco.scm \
%D%/packages/abiword.scm \
@@ -606,6 +607,7 @@ GNU_SYSTEM_MODULES = \
%D%/system.scm \
%D%/system/accounts.scm \
%D%/system/file-systems.scm \
+ %D%/system/image.scm \
%D%/system/install.scm \
%D%/system/keyboard.scm \
%D%/system/linux-container.scm \
@@ -626,6 +628,7 @@ GNU_SYSTEM_MODULES = \
%D%/build/activation.scm \
%D%/build/bootloader.scm \
%D%/build/cross-toolchain.scm \
+ %D%/build/image.scm \
%D%/build/file-systems.scm \
%D%/build/install.scm \
%D%/build/linux-boot.scm \