summaryrefslogtreecommitdiff
path: root/gnu/installer
diff options
context:
space:
mode:
authorFlorian Pelz <pelzflorian@pelzflorian.de>2020-04-09 02:17:22 +0200
committerFlorian Pelz <pelzflorian@pelzflorian.de>2020-04-09 02:42:54 +0000
commit91c231a2223440081426929828a23c7baa0214fd (patch)
treedb6adbba3f79d4cdaa1db0ee33938ced07763a0f /gnu/installer
parent543516ed0040df28eb15ea9b15ce905c038671c5 (diff)
downloadpatches-91c231a2223440081426929828a23c7baa0214fd.tar
patches-91c231a2223440081426929828a23c7baa0214fd.tar.gz
installer: Allow Alt+Shift toggle from non-Latin keyboard layouts.
Fixes <https://bugs.gnu.org/40493>. * gnu/installer/newt/keymap.scm (%non-latin-layouts): New variable. (%non-latin-variants): New variable. (%latin-layout+variants): New variable. (toggleable-latin-layout): New procedure to compute combined layouts. (run-keymap-page): Use it. (keyboard-layout->configuration): Apply it in config.scm. (run-layout-page): Mention Alt+Shift. * gnu/installer/keymap.scm (kmscon-update-keymap): Pass on XKB options. * gnu/installer/record.scm (<installer>): Adjust code comments. * gnu/installer.scm (apply-keymap): Pass on XKB options. (installer-steps): Adjust code comments. * gnu/packages/patches/kmscon-runtime-keymap-switch.patch: Apply XKB options.
Diffstat (limited to 'gnu/installer')
-rw-r--r--gnu/installer/keymap.scm10
-rw-r--r--gnu/installer/newt/keymap.scm61
-rw-r--r--gnu/installer/record.scm3
3 files changed, 63 insertions, 11 deletions
diff --git a/gnu/installer/keymap.scm b/gnu/installer/keymap.scm
index df9fc5e441..c42b308009 100644
--- a/gnu/installer/keymap.scm
+++ b/gnu/installer/keymap.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2020 Florian Pelz <pelzflorian@pelzflorian.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -154,8 +155,8 @@ Configuration Database, describing possible XKB configurations."
((models layouts)
(values models layouts)))))
-(define (kmscon-update-keymap model layout variant)
- "Update kmscon keymap with the provided MODEL, LAYOUT and VARIANT."
+(define (kmscon-update-keymap model layout variant options)
+ "Update kmscon keymap with the provided MODEL, LAYOUT, VARIANT and OPTIONS."
(and=>
(getenv "KEYMAP_UPDATE")
(lambda (keymap-file)
@@ -174,5 +175,8 @@ Configuration Database, describing possible XKB configurations."
(format port layout)
(put-u8 port 0)
- (format port variant)
+ (format port (or variant ""))
+ (put-u8 port 0)
+
+ (format port (or options ""))
(put-u8 port 0))))))
diff --git a/gnu/installer/newt/keymap.scm b/gnu/installer/newt/keymap.scm
index 8625afaa03..a555a1ecc1 100644
--- a/gnu/installer/newt/keymap.scm
+++ b/gnu/installer/newt/keymap.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2020 Florian Pelz <pelzflorian@pelzflorian.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,10 +41,12 @@
#:info-text
(case context
((param) (G_ "Please choose your keyboard layout. \
-It will only be used during the installation process."))
+It will only be used during the installation process. \
+Non-Latin layouts can be toggled with Alt+Shift."))
(else (G_ "Please choose your keyboard layout. \
It will be used during the install process, and for the installed system. \
-You can switch to different layout at any time from the parameters menu.")))
+Non-Latin layouts can be toggled with Alt+Shift. You can switch to a \
+different layout at any time from the parameters menu.")))
#:listbox-items layouts
#:listbox-item->text layout->text
#:sort-listbox-items? #f
@@ -112,10 +115,48 @@ You can switch to different layout at any time from the parameters menu.")))
variants))
(cut append <> <>)))
+(define %non-latin-layouts
+ ;; List of keyboard layouts marked as $nonlatin in xkeyboard-config.
+ ;; See comments in xkeyboard-config file /share/X11/xkb/rules/base.
+ ;; We ignore layouts that support Latin input: "kr"
+ '("am" "ara" "ben" "bd" "bg" "bt" "by" "cs" "deva" "ge" "gh"
+ "gr" "guj" "guru" "il" "in" "ir" "iku" "jp" "kan" "kh"
+ "la" "lao" "lk" "mk" "mm" "mn" "mv" "mal" "olck" "ori" "pk"
+ "ru" "scc" "sy" "syr" "tel" "th" "tj" "tam" "ua" "uz"
+ ;; The list from xkeyboard-config is incomplete. Add more layouts when
+ ;; noticed:
+ "et" "kz"))
+
+(define %non-latin-variants
+ '("cyrillic"))
+
+(define %latin-layout+variants
+ ;; These layout+variant combinations are Latin after all.
+ '(("ir" "ku")))
+
+(define (toggleable-latin-layout layout variant)
+ "If LAYOUT is a non-Latin layout, return a new combined layout,
+a variant, and options that allow the user to switch between the
+non-Latin and the Latin layout. Otherwise, return LAYOUT, VARIANT,
+and #f."
+ (if (and (not (equal? variant "latin"))
+ (not (member (list layout variant) %latin-layout+variants))
+ (or (member layout %non-latin-layouts)
+ (member variant %non-latin-variants)))
+ (let ((latin-layout (if (equal? variant "azerty") "fr" "us")))
+ (list
+ (string-append layout "," latin-layout)
+ ;; Comma to use variant only for non-Latin:
+ (and variant (string-append variant ","))
+ "grp:alt_shift_toggle"))
+ (list layout variant #f)))
+
(define* (run-keymap-page layouts #:key (context #f))
"Run a page asking the user to select a keyboard layout and variant. LAYOUTS
-is a list of supported X11-KEYMAP-LAYOUT. Return a list of two elements, the
-names of the selected keyboard layout and variant."
+is a list of supported X11-KEYMAP-LAYOUT. For non-Latin keyboard layouts, a
+second layout and toggle options will be added automatically. Return a list
+of three elements, the names of the selected keyboard layout, variant and
+options."
(define keymap-steps
(list
(installer-step
@@ -151,14 +192,20 @@ names of the selected keyboard layout and variant."
(lambda (variant)
(gettext (x11-keymap-variant-name variant)
"xkeyboard-config")))))
- (list layout (or variant ""))))
+ (toggleable-latin-layout layout variant)))
(format-result
(run-installer-steps #:steps keymap-steps)))
(define (keyboard-layout->configuration keymap)
"Return the operating system configuration snippet to install KEYMAP."
(match keymap
- ((name "")
+ ((name #f "grp:alt_shift_toggle")
+ `((keyboard-layout (keyboard-layout ,name
+ #:options '("grp:alt_shift_toggle")))))
+ ((name #f _)
`((keyboard-layout (keyboard-layout ,name))))
- ((name variant)
+ ((name variant "grp:alt_shift_toggle")
+ `((keyboard-layout (keyboard-layout ,name ,variant
+ #:options '("grp:alt_shift_toggle")))))
+ ((name variant _)
`((keyboard-layout (keyboard-layout ,name ,variant))))))
diff --git a/gnu/installer/record.scm b/gnu/installer/record.scm
index 7bc22e90e0..6ebd87f6a6 100644
--- a/gnu/installer/record.scm
+++ b/gnu/installer/record.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2020 Florian Pelz <pelzflorian@pelzflorian.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -63,7 +64,7 @@
(exit-error installer-exit-error)
;; procedure void -> void
(final-page installer-final-page)
- ;; procedure (layouts context) -> (list layout variant)
+ ;; procedure (layouts context) -> (list layout variant options)
(keymap-page installer-keymap-page)
;; procedure: (#:key supported-locales iso639-languages iso3166-territories)
;; -> glibc-locale