summaryrefslogtreecommitdiff
path: root/gnu/installer/hostname.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-12-05 14:45:53 +0900
committerLudovic Courtès <ludo@gnu.org>2019-01-17 14:04:23 +0100
commitb4658c258eaf7731dbb45409aedef58afc5de93a (patch)
tree0489f638052b9400dc0c5e7f41f5f29ea713499e /gnu/installer/hostname.scm
parentb51bde71a9385f4e81fbea258bfb9e8ff48be119 (diff)
downloadpatches-b4658c258eaf7731dbb45409aedef58afc5de93a.tar
patches-b4658c258eaf7731dbb45409aedef58afc5de93a.tar.gz
installer: Add hostname.
* gnu/installer/hostname.scm: New file. * gnu/installer.scm (installer-program): Use new module above. * gnu/local.mk (GNU_SYSTEM_MODULES): Add new file. * po/guix/POTFILES.in: Add new file.
Diffstat (limited to 'gnu/installer/hostname.scm')
-rw-r--r--gnu/installer/hostname.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/installer/hostname.scm b/gnu/installer/hostname.scm
new file mode 100644
index 0000000000..b8e823d0a8
--- /dev/null
+++ b/gnu/installer/hostname.scm
@@ -0,0 +1,23 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu installer hostname)
+ #:export (hostname->configuration))
+
+(define (hostname->configuration hostname)
+ `((host-name ,hostname)))