summaryrefslogtreecommitdiff
path: root/gnu/build
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2019-07-30 11:05:21 -0400
committerDavid Thompson <dthompson2@worcester.edu>2019-08-28 08:47:14 -0400
commit07d7175406210434d1fb9c100dc33a7d095f1627 (patch)
tree4b46890f3d6b8c0d52b44cc4cc8aafbc30ed39ca /gnu/build
parentdd2031169a334050c740c6772bdc32d984a9fede (diff)
downloadpatches-07d7175406210434d1fb9c100dc33a7d095f1627.tar
patches-07d7175406210434d1fb9c100dc33a7d095f1627.tar.gz
gnu: mingw-w64: Update to 6.0.0.
* gnu/packages/mingw.scm (mingw-w64): Update to 6.0.0. * gnu/packages/patches/mingw-w64-6.0.0-gcc.patch: New file. * gnu/packages/patches/mingw-w64-5.0rc2-gcc-4.9.3.patch: Delete it. * gnu/local.mk (dist_patch_DATA): Add new patch. Delete old patch. * gnu/build/cross-toolchain.scm (set-cross-path/mingw): Add additional autoconf-like substitutions.
Diffstat (limited to 'gnu/build')
-rw-r--r--gnu/build/cross-toolchain.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/build/cross-toolchain.scm b/gnu/build/cross-toolchain.scm
index 201b36ff7c..7ab0a355b0 100644
--- a/gnu/build/cross-toolchain.scm
+++ b/gnu/build/cross-toolchain.scm
@@ -130,7 +130,11 @@ C_*INCLUDE_PATH."
(substitute* (string-append mingw-headers "/crt/_mingw.h")
(("@MINGW_HAS_SECURE_API@")
- "#define MINGW_HAS_SECURE_API 1"))
+ "#define MINGW_HAS_SECURE_API 1")
+ (("@DEFAULT_WIN32_WINNT@")
+ "0x502")
+ (("@DEFAULT_MSVCRT_VERSION@")
+ "0x700"))
(let ((cpath (string-append mingw-headers "/include"
":" mingw-headers "/crt"