summaryrefslogtreecommitdiff
path: root/gnu/bootloader
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-06-11 12:58:38 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-07-15 12:53:37 +0200
commit8d858010b373485dcd999c30ec58bede53bd7ecd (patch)
tree6c8b2db7f90e6c9cb1da8d6f1eea8c8e8de1a37c /gnu/bootloader
parentc3b5b1bb49084ac816750cedc8f03a55884b2dd8 (diff)
downloadpatches-8d858010b373485dcd999c30ec58bede53bd7ecd.tar
patches-8d858010b373485dcd999c30ec58bede53bd7ecd.tar.gz
bootloader: Add u-boot.
* gnu/bootloader/u-boot.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * doc/guix.texi: Document it.
Diffstat (limited to 'gnu/bootloader')
-rw-r--r--gnu/bootloader/u-boot.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/bootloader/u-boot.scm b/gnu/bootloader/u-boot.scm
new file mode 100644
index 0000000000..963b0d7597
--- /dev/null
+++ b/gnu/bootloader/u-boot.scm
@@ -0,0 +1,47 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 David Craven <david@craven.ch>
+;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu bootloader u-boot)
+ #:use-module (gnu bootloader extlinux)
+ #:use-module (gnu bootloader)
+ #:use-module (gnu system)
+ #:use-module (gnu packages bootloaders)
+ #:use-module (guix gexp)
+ #:use-module (guix monads)
+ #:use-module (guix records)
+ #:use-module (guix utils)
+ #:export (u-boot-bootloader))
+
+(define install-u-boot
+ #~(lambda (bootloader device mount-point)
+ (if bootloader
+ (error "Failed to install U-Boot"))))
+
+
+
+;;;
+;;; Bootloader definitions.
+;;;
+
+(define u-boot-bootloader
+ (bootloader
+ (inherit extlinux-bootloader)
+ (name 'u-boot)
+ (package #f)
+ (installer install-u-boot)))