summaryrefslogtreecommitdiff
path: root/gnu.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-05-15 22:24:18 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2017-05-16 14:41:01 +0200
commitb09a8da4a2e50845a297e041762f3ff9e649c047 (patch)
tree41111b45d2af2ec06c0a7262f390bfd5e91639c1 /gnu.scm
parentce92d269fea0a2bfac0ac20414f77127d2f07500 (diff)
downloadpatches-b09a8da4a2e50845a297e041762f3ff9e649c047.tar
patches-b09a8da4a2e50845a297e041762f3ff9e649c047.tar.gz
bootloader: Add extlinux support.
* gnu/bootloader.scm: New file. * gnu/bootloader/extlinux.scm: New file. * gnu/bootloader/grub.scm: New file. * gnu/local.mk: Build new files. * gnu/system.scm: Adapt to new bootloader api. * gnu/scripts/system.scm: Adapt to new bootloader api. * gnu.scm: Remove (gnu system grub) and replace by (gnu bootloader) and (gnu bootloader grub) modules. * gnu/system/grub.scm: Moved content to gnu/bootloader/grub.scm. * gnu/system/vm: Replace (gnu system grub) module by (gnu bootloader). * gnu/tests.scm: Ditto. * gnu/tests/nfs.scm: Ditto.
Diffstat (limited to 'gnu.scm')
-rw-r--r--gnu.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu.scm b/gnu.scm
index 932e4cdd58..913ce61600 100644
--- a/gnu.scm
+++ b/gnu.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Joshua S. Grant <jgrant@parenthetical.io>
+;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,7 +35,8 @@
'((gnu system)
(gnu system mapped-devices)
(gnu system file-systems)
- (gnu system grub) ; 'grub-configuration'
+ (gnu bootloader)
+ (gnu bootloader grub)
(gnu system pam)
(gnu system shadow) ; 'user-account'
(gnu system linux-initrd)