summaryrefslogtreecommitdiff
path: root/etc
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-08 13:00:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-08 13:00:50 +0200
commit27783023993f9272ce422868d14529159c4a5218 (patch)
tree9013b08aa39e497b1fd8e01a05254278d83f0ff7 /etc
parentbe1e842ad78ac6c52fc7790f4a3ffd716673c111 (diff)
parentba6f2bda18ed19fa486a9c3e2c3baea6c66c6867 (diff)
downloadpatches-27783023993f9272ce422868d14529159c4a5218.tar
patches-27783023993f9272ce422868d14529159c4a5218.tar.gz
Merge branch 'master' into core-updates
Conflicts: etc/news.scm gnu/local.mk gnu/packages/check.scm gnu/packages/cross-base.scm gnu/packages/gimp.scm gnu/packages/java.scm gnu/packages/mail.scm gnu/packages/sdl.scm gnu/packages/texinfo.scm gnu/packages/tls.scm gnu/packages/version-control.scm
Diffstat (limited to 'etc')
-rw-r--r--etc/news.scm8
-rw-r--r--etc/release-manifest.scm25
2 files changed, 26 insertions, 7 deletions
diff --git a/etc/news.scm b/etc/news.scm
index 8c6f5f8a03..ba15f12ce6 100644
--- a/etc/news.scm
+++ b/etc/news.scm
@@ -10,6 +10,14 @@
(channel-news
(version 0)
+ (entry (commit "0468455e7d279c89ea3ad1b51935efb2b785ec47")
+ (title (en "Rottlog service added to @code{%base-services}"))
+ (body (en "An instance of @code{rottlog-service-type}, the system
+service responsible for log rotation, has been added to @code{%base-services}.
+If your operating system configuration for Guix System is explicitly adding
+@code{rottlog-service-type} to the services, you should now remove it. See
+the ``Log Rotation'' section of the manual for more information.")))
+
(entry (commit "b6bee63bed4f013064c0d902e7c8b83ed7514ade")
(title (en "@code{guile} package now refers to version 3.0"))
(body (en "The @code{guile} package has been upgraded to version 3.0
diff --git a/etc/release-manifest.scm b/etc/release-manifest.scm
index 67b92c3921..91471bd03b 100644
--- a/etc/release-manifest.scm
+++ b/etc/release-manifest.scm
@@ -23,6 +23,7 @@
(guix packages)
(guix profiles)
((gnu ci) #:select (%cross-targets))
+ (guix utils)
(srfi srfi-1)
(srfi srfi-26))
@@ -61,11 +62,17 @@ TARGET."
(define %packages-to-cross-build
;; Packages that must be cross-buildable from x86_64-linux.
- (cons (@ (gnu packages gcc) gcc)
- (map specification->package
- '("coreutils" "grep" "sed" "findutils" "diffutils" "patch"
- "gawk" "gettext" "gzip" "xz"
- "hello" "guile@2.2" "zlib"))))
+ ;; FIXME: Add (@ (gnu packages gcc) gcc) when <https://bugs.gnu.org/40463>
+ ;; is fixed.
+ (append (list (@ (gnu packages guile) guile-2.2/fixed))
+ (map specification->package
+ '("coreutils" "grep" "sed" "findutils" "diffutils" "patch"
+ "gawk" "gettext" "gzip" "xz"
+ "hello" "zlib"))))
+
+(define %packages-to-cross-build-for-mingw
+ ;; Many things don't build for MinGW. Restrict to what's known to work.
+ (map specification->package '("hello")))
(define %cross-bootstrap-targets
;; Cross-compilation triplets for which 'bootstrap-tarballs' must be
@@ -91,8 +98,12 @@ TARGET."
(append-map (lambda (target)
(map (cut package->manifest-entry* <> "x86_64-linux"
#:target target)
- %packages-to-cross-build))
- %cross-targets)))
+ (if (target-mingw? target)
+ %packages-to-cross-build-for-mingw
+ %packages-to-cross-build)))
+ ;; XXX: Important bits like libsigsegv and libffi don't support
+ ;; RISCV at the moment, so don't require RISCV support.
+ (delete "riscv64-linux-gnu" %cross-targets))))
(define %cross-bootstrap-manifest
(manifest