summaryrefslogtreecommitdiff
path: root/etc/indent-package.el.in
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-13 18:47:15 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-13 18:49:31 +0100
commit557d9c8d7a843bf06e75b4e1a742654ccf951fa3 (patch)
treedcd96026be9c5c408ed08f9f3061962c00d0d39d /etc/indent-package.el.in
parent608a50b66c73d5bdfd224195b839e01b781c354c (diff)
downloadpatches-557d9c8d7a843bf06e75b4e1a742654ccf951fa3.tar
patches-557d9c8d7a843bf06e75b4e1a742654ccf951fa3.tar.gz
etc: Support indentation of whole files.
* etc/indent-package.el.in: Rename to... * etc/indent-code.el.in: ... this. Add case for a single argument. * doc/contributing.texi (Formatting Code): Adjust accordingly. * configure.ac: Likewise.
Diffstat (limited to 'etc/indent-package.el.in')
-rwxr-xr-xetc/indent-package.el.in53
1 files changed, 0 insertions, 53 deletions
diff --git a/etc/indent-package.el.in b/etc/indent-package.el.in
deleted file mode 100755
index 3188809f0b..0000000000
--- a/etc/indent-package.el.in
+++ /dev/null
@@ -1,53 +0,0 @@
-#!@EMACS@ --script
-;;; indent-package.el --- Run Emacs to indent a package definition.
-
-;; Copyright © 2017 Alex Kost <alezost@gmail.com>
-
-;; This file is part of GNU Guix.
-
-;; GNU Guix is free software; you can redistribute it and/or modify
-;; it under the terms of the GNU General Public License as published by
-;; the Free Software Foundation, either version 3 of the License, or
-;; (at your option) any later version.
-
-;; GNU Guix is distributed in the hope that it will be useful,
-;; but WITHOUT ANY WARRANTY; without even the implied warranty of
-;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;; GNU General Public License for more details.
-
-;; You should have received a copy of the GNU General Public License
-;; along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-;;; Commentary:
-
-;; This scripts indents the given package definition in the specified file
-;; using Emacs.
-
-;;; Code:
-
-;; Load Scheme indentation rules from the current directory.
-(with-temp-buffer
- (scheme-mode)
- (let ((default-directory (file-name-as-directory "."))
- (enable-local-variables :all))
- (hack-dir-local-variables)
- (hack-local-variables-apply)))
-
-(pcase command-line-args-left
- (`(,file-name ,package-name)
- (find-file file-name)
- (goto-char (point-min))
- (if (re-search-forward (concat "^(define\\(-public\\) +"
- package-name)
- nil t)
- (let ((indent-tabs-mode nil))
- (beginning-of-defun)
- (indent-sexp)
- (save-buffer)
- (message "Done!"))
- (error "Package '%s' not found in '%s'"
- package-name file-name)))
- (x
- (error "Usage: indent-package.el FILE PACKAGE")))
-
-;;; indent-package.el ends here