summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-08-28 21:44:14 +0200
committerAndreas Enge <andreas@enge.fr>2013-08-28 21:44:14 +0200
commit575ed8d5b3184493c8fe233b4d5128c495b7c652 (patch)
tree0680cdacabb64b918e2ab67353f1461cea9853ad /doc
parent3d1b29a5c5bfe6171caafd243663b77259924ed2 (diff)
downloadpatches-575ed8d5b3184493c8fe233b4d5128c495b7c652.tar
patches-575ed8d5b3184493c8fe233b4d5128c495b7c652.tar.gz
doc: Create own Makefile.am in subdirectory.
* doc/Makefile.am: New file. * Makefile.am: Reference subdirectory doc.
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000000..c40f48ca4a
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,45 @@
+# GNU Guix --- Functional package management for GNU
+# Copyright © 2013 Andreas Enge <andreas@enge.fr>
+#
+# This file is part of GNU Guix.
+#
+# GNU Guix is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or (at
+# your option) any later version.
+#
+# GNU Guix is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+info_TEXINFOS = guix.texi
+EXTRA_DIST = \
+ fdl-1.3.texi \
+ images/bootstrap-graph.dot \
+ images/bootstrap-graph.eps
+
+infoimagedir = $(infodir)/images
+dist_infoimage_DATA = images/bootstrap-graph.png
+
+# Try hard to obtain an image size and aspect that's reasonable for inclusion
+# in an Info or PDF document.
+DOT_OPTIONS = \
+ -Tpng -Gratio=.9 -Gnodesep=.005 -Granksep=.00005 \
+ -Nfontsize=9 -Nheight=.1 -Nwidth=.1
+
+.dot.png:
+ dot -Tpng $(DOT_OPTIONS) < "$<" > "$@.tmp"
+ mv "$@.tmp" "$@"
+
+.dot.eps:
+ dot -Teps $(DOT_OPTIONS) < "$<" > "$@.tmp"
+ mv "$@.tmp" "$@"
+
+guix.pdf: images/bootstrap-graph.png
+guix.info: images/bootstrap-graph.png
+guix.ps: images/bootstrap-graph.eps
+