summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-08-16 21:15:45 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-08-27 19:45:06 -0400
commit3aae8145a73fc7116694c3d8bfced11ae332b491 (patch)
tree0e3cefd8848c29d7a4791540c2fc4c90c4a53da6 /doc
parent140b3048155d8fe4b8598786c014139ac5a91706 (diff)
downloadpatches-3aae8145a73fc7116694c3d8bfced11ae332b491.tar
patches-3aae8145a73fc7116694c3d8bfced11ae332b491.tar.gz
import: Add Ruby gem importer.
* gnu/scripts/import.scm (importers): Add "gem". * gnu/import/gem.scm: New file. * gnu/scripts/import/gem.scm: New file. * Makefile.am (MODULES): Add them. * guix.texi ("invoking guix import"): Document it.
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi19
1 files changed, 19 insertions, 0 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 6ea143f37b..88e1ff7f77 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -3894,6 +3894,25 @@ package:
guix import pypi itsdangerous
@end example
+@item gem
+@cindex gem
+Import meta-data from @uref{https://rubygems.org/,
+RubyGems}@footnote{This functionality requires Guile-JSON to be
+installed. @xref{Requirements}.}. Information is taken from the
+JSON-formatted description available at @code{rubygems.org} and includes
+most relevant information, including runtime dependencies. There are
+some caveats, however. The meta-data doesn't distinguish between
+synopses and descriptions, so the same string is used for both fields.
+Additionally, the details of non-Ruby dependencies required to build
+native extensions is unavailable and left as an exercise to the
+packager.
+
+The command below imports meta-data for the @code{rails} Ruby package:
+
+@example
+guix import gem rails
+@end example
+
@item cpan
@cindex CPAN
Import meta-data from @uref{https://www.metacpan.org/, MetaCPAN}.