summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-02 22:49:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-04 11:23:52 +0200
commit88c8f247e594239807aafe80d5e8b084d07e32f6 (patch)
treec854d26b3d2d3d287230699fca10b698d6217e0b /doc
parentb316caaa9cda8bf2a8b20d5ba87b5d306f3b39bd (diff)
downloadpatches-88c8f247e594239807aafe80d5e8b084d07e32f6.tar
patches-88c8f247e594239807aafe80d5e8b084d07e32f6.tar.gz
build: Add minify build system.
* guix/build-system/minify.scm: New file. * guix/build/minify-build-system: New file. * Makefile.am (MODULES): Add new files. * doc/guix.texi (Build Systems): Document minify-build-system.
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi15
1 files changed, 15 insertions, 0 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 2bb820b46c..88bf0bb621 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -3576,6 +3576,21 @@ specified with the @code{#:glib} parameter.
Both phases are executed after the @code{install} phase.
@end defvr
+@defvr {Scheme Variable} minify-build-system
+This variable is exported by @code{(guix build-system minify)}. It
+implements a minification procedure for simple JavaScript packages.
+
+It adds @code{uglify-js} to the set of inputs and uses it to compress
+all JavaScript files in the @file{src} directory. A different minifier
+package can be specified with the @code{#:uglify-js} parameter, but it
+is expected that the package writes the minified code to the standard
+output.
+
+When the input JavaScript files are not all located in the @file{src}
+directory, the parameter @code{#:javascript-files} can be used to
+specify a list of file names to feed to the minifier.
+@end defvr
+
@defvr {Scheme Variable} ocaml-build-system
This variable is exported by @code{(guix build-system ocaml)}. It implements
a build procedure for @uref{https://ocaml.org, OCaml} packages, which consists