summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-06-16 10:50:06 +0200
committerFederico Beffa <beffa@fbengineering.ch>2015-07-08 10:53:05 +0200
commit7f74a931ddccdb3b42558f8f8ee29b309d9231b9 (patch)
tree1804fcf24967f92cd15e4ee3c2ac13e5091bb8dd /doc
parent575b4b092d73403381277625794042a7b7253cfe (diff)
downloadpatches-7f74a931ddccdb3b42558f8f8ee29b309d9231b9.tar
patches-7f74a931ddccdb3b42558f8f8ee29b309d9231b9.tar.gz
import: Add 'elpa' importer.
* guix/import/elpa.scm: New file. * guix/scripts/import.scm: Add "elpa" to 'importers'. * guix/scripts/import/elpa.scm: New file. * Makefile.am (MODULES): Add 'guix/import/elpa.scm' and 'guix/scripts/import/elpa.scm'. (SCM_TESTS): Add 'tests/elpa.scm'. * doc/guix.texi (Invoking guix import): Document it. * tests/elpa.scm: New file. * po/guix/POTFILES.in: Add 'guix/scripts/import/elpa.scm'.
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi28
1 files changed, 28 insertions, 0 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 284d667f34..d10279e992 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -3856,6 +3856,34 @@ package name by a hyphen and a version number as in the following example:
@example
guix import hackage mtl-2.1.3.1
@end example
+
+@item elpa
+@cindex elpa
+Import meta-data from an Emacs Lisp Package Archive (ELPA) package
+repository (@pxref{Packages,,, emacs, The GNU Emacs Manual}).
+
+Specific command-line options are:
+
+@table @code
+@item --archive=@var{repo}
+@itemx -a @var{repo}
+@var{repo} identifies the archive repository from which to retrieve the
+information. Currently the supported repositories and their identifiers
+are:
+@itemize -
+@item
+@uref{"http://elpa.gnu.org/packages", GNU}, selected by the @code{gnu}
+identifier. This is the default.
+
+@item
+@uref{"http://stable.melpa.org/packages", MELPA-Stable}, selected by the
+@code{melpa-stable} identifier.
+
+@item
+@uref{"http://melpa.org/packages", MELPA}, selected by the @code{melpa}
+identifier.
+@end itemize
+@end table
@end table
The structure of the @command{guix import} code is modular. It would be