summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2016-08-23 05:23:55 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-07-14 12:20:48 +0200
commit09a1f92f61d1ab11d2cf9f7a0983f4fc9f436f57 (patch)
tree30c9a37b4b75c5e7cf8c52f629014aca54308a56 /doc
parent041e03847beda7fd9cfb92f87db14c5b33179f29 (diff)
downloadpatches-09a1f92f61d1ab11d2cf9f7a0983f4fc9f436f57.tar
patches-09a1f92f61d1ab11d2cf9f7a0983f4fc9f436f57.tar.gz
build: Add node-build-system.
* guix/build/node-build-system.scm: New file. * guix/build-system/node.scm: New file. * guix/build/json.scm: New file. * doc/guix.texi: Document it. * Makefile.am: Added new files. Co-Authored-By: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi11
1 files changed, 11 insertions, 0 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 458fca20af..6ed77fe267 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -6346,6 +6346,17 @@ the module (in the "arguments" form of a package using the
linux-module-build-system, use the key #:linux to specify it).
@end defvr
+@defvr {Scheme Variable} node-build-system
+This variable is exported by @code{(guix build-system node)}. It
+implements the build procedure used by @uref{http://nodejs.org,
+Node.js}, which implements an approximation of the @code{npm install}
+command, followed by an @code{npm test} command.
+
+Which Node.js package is used to interpret the @code{npm} commands can
+be specified with the @code{#:node} parameter which defaults to
+@code{node}.
+@end defvr
+
Lastly, for packages that do not need anything as sophisticated, a
``trivial'' build system is provided. It is trivial in the sense that
it provides basically no support: it does not pull any implicit inputs,