summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-29 16:56:49 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-14 12:36:49 +0100
commit5f7a1a4def8494940a4a2bc3728fb9cd927a14f8 (patch)
tree3a94591cfa34e81de8ef88e476a4e368cf033272 /doc
parent535e2a2feedf95c8a3b2ef390ad9c2e5935b60be (diff)
downloadpatches-5f7a1a4def8494940a4a2bc3728fb9cd927a14f8.tar
patches-5f7a1a4def8494940a4a2bc3728fb9cd927a14f8.tar.gz
build: Add Ant build system.
* guix/build-system/ant.scm: New file. * guix/build/ant-build-system: New file. * Makefile.am (MODULES): Add new files. * doc/guix.texi (Build Systems): Document ant-build-system.
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi21
1 files changed, 21 insertions, 0 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index f7deafa516..7509ea9dc2 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -2720,6 +2720,27 @@ of @var{gnu-build-system}, and differ mainly in the set of inputs
implicitly added to the build process, and in the list of phases
executed. Some of these build systems are listed below.
+@defvr {Scheme Variable} ant-build-system
+This variable is exported by @code{(guix build-system ant)}. It
+implements the build procedure for Java packages that can be built with
+@url{http://ant.apache.org/, Ant build tool}.
+
+It adds both @code{ant} and the @dfn{Java Development Kit} (JDK) as
+provided by the @code{icedtea} package to the set of inputs. Different
+packages can be specified with the @code{#:ant} and @code{#:jdk}
+parameters, respectively.
+
+When the original package does not provide a suitable Ant build file,
+the parameter @code{#:jar-name} can be used to generate a minimal Ant
+build file @file{build.xml} with tasks to build the specified jar
+archive.
+
+The parameter @code{#:build-target} can be used to specify the Ant task
+that should be run during the @code{build} phase. By default the
+``jar'' task will be run.
+
+@end defvr
+
@defvr {Scheme Variable} cmake-build-system
This variable is exported by @code{(guix build-system cmake)}. It
implements the build procedure for packages using the