summaryrefslogtreecommitdiff
path: root/doc/package-hello.json
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-16 22:22:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-04-16 23:41:52 +0200
commitc9f321e52a99dea93fcc099372ea0167150b9aac (patch)
tree7ded3f741ae42ee176f9687e917bbbd724da6fe2 /doc/package-hello.json
parent3c0422b9be649e0a09caa0b893713a9f07855cd3 (diff)
downloadpatches-c9f321e52a99dea93fcc099372ea0167150b9aac.tar
patches-c9f321e52a99dea93fcc099372ea0167150b9aac.tar.gz
doc: Document building and installing from JSON files.
* doc/guix.texi (Invoking guix package): Augment pargraphs for "--install-from-file". (Invoking guix build): Document building from JSON files. * doc/package-hello.json: New file. * doc/local.mk (EXTRA_DIST): Add it.
Diffstat (limited to 'doc/package-hello.json')
-rw-r--r--doc/package-hello.json31
1 files changed, 31 insertions, 0 deletions
diff --git a/doc/package-hello.json b/doc/package-hello.json
new file mode 100644
index 0000000000..a47e266e4b
--- /dev/null
+++ b/doc/package-hello.json
@@ -0,0 +1,31 @@
+[
+ {
+ "name": "myhello",
+ "version": "2.10",
+ "source": "mirror://gnu/hello/hello-2.10.tar.gz",
+ "build-system": "gnu",
+ "arguments": {
+ "tests?": false
+ }
+ "home-page": "https://www.gnu.org/software/hello/",
+ "synopsis": "Hello, GNU world: An example GNU package",
+ "description": "GNU Hello prints a greeting.",
+ "license": "GPL-3.0+",
+ "native-inputs": ["gettext"]
+ },
+ {
+ "name": "greeter",
+ "version": "1.0",
+ "source": "https://example.com/greeter-1.0.tar.gz",
+ "build-system": "gnu",
+ "arguments": {
+ "test-target": "foo",
+ "parallel-build?": false,
+ },
+ "home-page": "https://example.com/",
+ "synopsis": "Greeter using GNU Hello",
+ "description": "This is a wrapper around GNU Hello.",
+ "license": "GPL-3.0+",
+ "inputs": ["myhello", "hello"]
+ }
+]