summaryrefslogtreecommitdiff
path: root/doc/local.mk
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-08 14:35:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-18 11:38:14 +0200
commit7bc46ecc34ceb042ff890e5d306d0a2a736e891d (patch)
tree9f5952d815edc41bae127e101ee1781ed1eb809a /doc/local.mk
parenta870b80046d532329762095683d8f9c33538eaf1 (diff)
downloadpatches-7bc46ecc34ceb042ff890e5d306d0a2a736e891d.tar
patches-7bc46ecc34ceb042ff890e5d306d0a2a736e891d.tar.gz
doc: Add Guix Cookbook.
* .gitignore: Update ignore list. * Makefile.am (assert-no-store-file-names): Exclude the cookbook. * bootstrap: Generate po files for cookbook translations. * doc/guix-cookbook.texi: New file. * doc/local.mk (info_TEXINFOS): Add it; add a rule to build cookbook translations. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): New variable. (EXTRA_DIST): Add cookbook pot file and po files. (doc-po-update-cookbook-%): New target. (doc-pot-update): Also update cookbook pot file. (doc-po-update): Also update cookbook po files.
Diffstat (limited to 'doc/local.mk')
-rw-r--r--doc/local.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/doc/local.mk b/doc/local.mk
index 336e961c4f..850612605b 100644
--- a/doc/local.mk
+++ b/doc/local.mk
@@ -26,7 +26,8 @@ info_TEXINFOS = %D%/guix.texi \
%D%/guix.es.texi \
%D%/guix.fr.texi \
%D%/guix.ru.texi \
- %D%/guix.zh_CN.texi
+ %D%/guix.zh_CN.texi \
+ %D%/guix-cookbook.texi
%C%_guix_TEXINFOS = \
%D%/contributing.texi \
@@ -108,6 +109,12 @@ $(srcdir)/%D%/guix.%.texi: po/doc/guix-manual.%.po $(srcdir)/%D%/contributing.%.
-$(AM_V_POXREF)$(xref_command)
-mv "$@.tmp" "$@"
+$(srcdir)/%D%/guix-cookbook.%.texi: po/doc/guix-cookbook.%.po
+ -$(AM_V_PO4A)$(PO4A_TRANSLATE) $(PO4A_PARAMS) -m "%D%/guix-cookbook.texi" -p "$<" -l "$@.tmp"
+ -sed -i "s|guix-cookbook\.info|$$(basename "$@" | sed 's|texi$$|info|')|" "$@.tmp"
+ -$(AM_V_POXREF)$(xref_command)
+ -mv "$@.tmp" "$@"
+
$(srcdir)/%D%/contributing.%.texi: po/doc/guix-manual.%.po
-$(AM_V_PO4A)$(PO4A_TRANSLATE) $(PO4A_PARAMS) -m "%D%/contributing.texi" -p "$<" -l "$@.tmp"
-$(AM_V_POXREF)$(xref_command)