summaryrefslogtreecommitdiff
path: root/distro
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2012-12-16 20:14:02 +0000
committerNikita Karetnikov <nikita@karetnikov.org>2012-12-17 15:26:58 +0000
commitd8989c2394dc90cdc1bbd1f97bf6de5b1b8aed0e (patch)
tree9ac9f33f9781455db64b2004479dc5cf00aff83b /distro
parentc43e00616485e4b4c9e43fdd7e7537ba7e2fec77 (diff)
downloadpatches-d8989c2394dc90cdc1bbd1f97bf6de5b1b8aed0e.tar
patches-d8989c2394dc90cdc1bbd1f97bf6de5b1b8aed0e.tar.gz
distro: Add Check.
* distro/packages/check.scm: New file. * Makefile.am (MODULES): Add it.
Diffstat (limited to 'distro')
-rw-r--r--distro/packages/check.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/distro/packages/check.scm b/distro/packages/check.scm
new file mode 100644
index 0000000000..f997262c09
--- /dev/null
+++ b/distro/packages/check.scm
@@ -0,0 +1,49 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages check)
+ #:use-module (distro)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public check
+ (package
+ (name "check")
+ (version "0.9.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/check/"
+ version "/check-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jcahzrvxcnp5chdn2x46l0y4aba8d8yd70lljfin7h5knxrlyhs"))))
+ (build-system gnu-build-system)
+ (home-page "http://check.sourceforge.net/")
+ (synopsis
+ "Check, a unit testing framework for C")
+ (description
+ "Check is a unit testing framework for C. It features a simple
+interface for defining unit tests, putting little in the way of the
+developer. Tests are run in a separate address space, so Check can
+catch both assertion failures and code errors that cause segmentation
+faults or other signals. The output from unit tests can be used within
+source code editors and IDEs.")
+ (license lgpl2.1+)))