summaryrefslogtreecommitdiff
path: root/distro/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-12 23:10:26 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-12 23:35:04 +0100
commit62cab99c3297a066f466780bb4d83a4f142538c7 (patch)
treed17374f770ad043356b915967f8960ab9f8cc7c0 /distro/packages
parentddc29a782eac30fcf4ff1f07677aa2896dc140e4 (diff)
downloadpatches-62cab99c3297a066f466780bb4d83a4f142538c7.tar
patches-62cab99c3297a066f466780bb4d83a4f142538c7.tar.gz
Add (guix download) and (guix build download).
* guix/download.scm, guix/build/download.scm: New files. * Makefile.am (MODULES): Add them. * tests/builders.scm ("url-fetch"): New test. * distro/packages/bootstrap.scm (bootstrap-origin): Support `url-fetch'. * guix/snix.scm (snix-derivation->guix-package): Use `url-fetch' instead of `http-fetch'.
Diffstat (limited to 'distro/packages')
-rw-r--r--distro/packages/bootstrap.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/distro/packages/bootstrap.scm b/distro/packages/bootstrap.scm
index 533ff42987..95a7de444c 100644
--- a/distro/packages/bootstrap.scm
+++ b/distro/packages/bootstrap.scm
@@ -21,6 +21,7 @@
#:use-module (guix packages)
#:use-module (guix ftp)
#:use-module (guix http)
+ #:use-module (guix download)
#:use-module (guix build-system)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
@@ -70,6 +71,8 @@
(boot http-fetch))
((eq? orig-method ftp-fetch)
(boot ftp-fetch))
+ ((eq? orig-method url-fetch)
+ (boot url-fetch))
(else orig-method))))))
(define (package-from-tarball name* source* program-to-test description*)