summaryrefslogtreecommitdiff
path: root/distro/packages/time.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/time.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadpatches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar
patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/time.scm')
-rw-r--r--distro/packages/time.scm66
1 files changed, 0 insertions, 66 deletions
diff --git a/distro/packages/time.scm b/distro/packages/time.scm
deleted file mode 100644
index 0b7bde9a1b..0000000000
--- a/distro/packages/time.scm
+++ /dev/null
@@ -1,66 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages time)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public time
- (package
- (name "time")
- (version "1.7")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/time/time-"
- version ".tar.gz"))
- (sha256
- (base32
- "0va9063fcn7xykv658v2s9gilj2fq4rcdxx2mn2mmy1v4ndafzp3"))))
- (build-system gnu-build-system)
- (arguments
- '(#:phases
- (alist-replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; This old `configure' script doesn't support
- ;; variables passed as arguments.
- (let ((out (assoc-ref outputs "out")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)))))
- %standard-phases)))
- (home-page "http://www.gnu.org/software/time/")
- (synopsis
- "GNU Time, a tool that runs programs and summarizes the system
-resources they use")
- (description
- "The 'time' command runs another program, then displays information
-about the resources used by that program, collected by the system while
-the program was running. You can select which information is reported
-and the format in which it is shown, or have 'time' save the information
-in a file instead of displaying it on the screen.
-
-The resources that 'time' can report on fall into the general categories
-of time, memory, and I/O and IPC calls. Some systems do not provide
-much information about program resource use; 'time' reports unavailable
-information as zero values.")
- (license gpl2+)))