summaryrefslogtreecommitdiff
path: root/distro/packages/less.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/less.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadpatches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar
patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/less.scm')
-rw-r--r--distro/packages/less.scm51
1 files changed, 0 insertions, 51 deletions
diff --git a/distro/packages/less.scm b/distro/packages/less.scm
deleted file mode 100644
index 1f05b50e1e..0000000000
--- a/distro/packages/less.scm
+++ /dev/null
@@ -1,51 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages less)
- #:use-module (guix licenses)
- #:use-module (distro packages ncurses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public less
- (package
- (name "less")
- (version "451")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/less/less-"
- version ".tar.gz"))
- (sha256
- (base32
- "0mszdd9m1dsbg59pav62swg9f87xmjpfspcw2jsazzksciy2is4z"))))
- (build-system gnu-build-system)
- (inputs `(("ncurses" ,ncurses)))
- (home-page "https://www.gnu.org/software/less/")
- (synopsis
- "GNU less is a program similar to more, but which allows backward
-movement in the file as well as forward movement")
- (description
- "GNU less is a program similar to more, but which allows backward
-movement in the file as well as forward movement. Also, less does not
-have to read the entire input file before starting, so with large input
-files it starts up faster than text editors like vi. Less uses
-termcap (or terminfo on some systems), so it can run on a variety of
-terminals. There is even limited support for hardcopy terminals.")
- (license gpl3+))) ; some files are under GPLv2+ \ No newline at end of file