summaryrefslogtreecommitdiff
path: root/distro/packages/flex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/flex.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadpatches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar
patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/flex.scm')
-rw-r--r--distro/packages/flex.scm63
1 files changed, 0 insertions, 63 deletions
diff --git a/distro/packages/flex.scm b/distro/packages/flex.scm
deleted file mode 100644
index 2cfdbfe23a..0000000000
--- a/distro/packages/flex.scm
+++ /dev/null
@@ -1,63 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages flex)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (distro)
- #:use-module (distro packages m4)
- #:use-module (distro packages bison)
- #:use-module (distro packages indent))
-
-(define-public flex
- (package
- (name "flex")
- (version "2.5.37")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/flex/flex-"
- version ".tar.bz2"))
- (sha256
- (base32
- "0ah5mi4j62b85a9rllv1004mzjb5cd0mn4glvz13p88rpx77pahp"))))
- (build-system gnu-build-system)
- (arguments
- '(#:patches (list (assoc-ref %build-inputs "patch/bison-tests"))))
- (inputs `(("patch/bison-tests" ,(search-patch "flex-bison-tests.patch"))
- ("bison" ,bison)
- ("indent" ,indent)))
- (propagated-inputs `(("m4" ,m4)))
- (home-page "http://flex.sourceforge.net/")
- (synopsis "A fast lexical analyser generator")
- (description
- "Flex is a tool for generating scanners. A scanner, sometimes
-called a tokenizer, is a program which recognizes lexical patterns in
-text. The flex program reads user-specified input files, or its standard
-input if no file names are given, for a description of a scanner to
-generate. The description is in the form of pairs of regular expressions
-and C code, called rules. Flex generates a C source file named,
-\"lex.yy.c\", which defines the function yylex(). The file \"lex.yy.c\"
-can be compiled and linked to produce an executable. When the executable
-is run, it analyzes its input for occurrences of text matching the
-regular expressions for each rule. Whenever it finds a match, it
-executes the corresponding C code.")
- (license (bsd-style "file://COPYING"
- "See COPYING in the distribution."))))
-