summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-12-29 19:53:05 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-29 19:53:05 +0100
commitbb0a70e1f1bc28b49a6c3c58e4d9feeb0f3b92ee (patch)
tree8e93537fe2286bc35de1bded3b411418ef9b82a1 /configure.ac
parent490c6528edaa8db1acbcc0fa6b6bad6f436a0e95 (diff)
downloadpatches-bb0a70e1f1bc28b49a6c3c58e4d9feeb0f3b92ee.tar
patches-bb0a70e1f1bc28b49a6c3c58e4d9feeb0f3b92ee.tar.gz
build: Improve documentation of Nix-related options.
* configure.ac: Add documentation for --with-nix and --with-nixpkgs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e7bc44dca2..799b3e8152 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,7 +62,8 @@ GUIX_CHECK_SRFI_37
AM_CONDITIONAL([INSTALL_SRFI_37], [test "x$ac_cv_guix_srfi_37_broken" = xyes])
AC_ARG_WITH([nix-prefix],
- [AS_HELP_STRING([--with-nix-prefix=DIR], [search for Nix in DIR])],
+ [AS_HELP_STRING([--with-nix-prefix=DIR],
+ [search for Nix in DIR (for testing purposes and '--disable-daemon' builds)])],
[case "$withval" in
yes|no) ;;
*)
@@ -86,7 +87,8 @@ if test "x$NIX_INSTANTIATE" = "x"; then
fi
AC_ARG_WITH([nixpkgs],
- [AS_HELP_STRING([--with-nixpkgs=DIR], [search for Nixpkgs in DIR])],
+ [AS_HELP_STRING([--with-nixpkgs=DIR],
+ [search for Nixpkgs in DIR (for testing purposes only)])],
[case "$withval" in
yes|no) AC_MSG_ERROR([Please use `--with-nixpkgs=DIR'.]);;
*) NIXPKGS="$withval";;