summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-05-05 11:01:50 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2017-05-05 19:52:38 +0200
commita70b784708fb5e1b78430aa793d89ca04bc641a8 (patch)
tree3288b5d39057fbc18f9cc522414307f079647d5b /configure.ac
parentd2b18f1211631e812e0a06ceb8ffcd5d42d89915 (diff)
downloadpatches-a70b784708fb5e1b78430aa793d89ca04bc641a8.tar
patches-a70b784708fb5e1b78430aa793d89ca04bc641a8.tar.gz
guix: git: Add new module.
* guix/git.scm: New file. * configure.ac: Check for (guile git). * Makefile.am: Build guix/git.scm if (guile git) is available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dc3d8f377f..c937e948d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,6 +104,10 @@ dnl Guile-JSON is used in various places.
GUILE_MODULE_AVAILABLE([have_guile_json], [(json)])
AM_CONDITIONAL([HAVE_GUILE_JSON], [test "x$have_guile_json" = "xyes"])
+dnl Check for Guile-Git.
+GUILE_MODULE_AVAILABLE([have_guile_git], [(git)])
+AM_CONDITIONAL([HAVE_GUILE_GIT], [test "x$have_guile_git" = "xyes"])
+
dnl Make sure we have a full-fledged Guile.
GUIX_ASSERT_GUILE_FEATURES([regex posix socket net-db threads])