summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-03-09 22:09:12 +0100
committerLudovic Courtès <ludo@gnu.org>2014-03-09 22:09:58 +0100
commit834129e0e2984fa615c8958de3964dabd7f6972c (patch)
tree8cffcd50a4847000e533059c3c3babed4d3b42f1 /configure.ac
parent59f704dff69f28149acdfde372ad8faebbdfdfb5 (diff)
downloadpatches-834129e0e2984fa615c8958de3964dabd7f6972c.tar
patches-834129e0e2984fa615c8958de3964dabd7f6972c.tar.gz
Change the default store file name to /gnu/store.
* configure.ac: Change the default 'storedir' to /gnu/store. Print $storedir. * doc/guix.texi: Replace "/nix/store" by "/gnu/store", except where describing Nix compatibility. * Makefile.am: Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 749672f15b..d5a89c915b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,11 +26,15 @@ GUIX_ASSERT_SUPPORTED_SYSTEM
AC_ARG_WITH(store-dir,
AC_HELP_STRING([--with-store-dir=PATH],
- [path of the store (defaults to /nix/store)]),
+ [file name of the store (defaults to /gnu/store)]),
[storedir="$withval"],
- [storedir="/nix/store"])
+ [storedir="/gnu/store"])
AC_SUBST(storedir)
+dnl Better be verbose.
+AC_MSG_CHECKING([for the store directory])
+AC_MSG_RESULT([$storedir])
+
AC_ARG_ENABLE([daemon],
[AS_HELP_STRING([--disable-daemon], [build the Nix daemon (C++)])],
[guix_build_daemon="$enableval"],