summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-05-05 11:01:50 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2017-06-09 09:48:26 +0200
commit6b7b3ca9813d00b734d1318e40e6c10d17859d12 (patch)
tree74cacc44111ac45a5bef1361e4877ba0ffb91535 /configure.ac
parent6fe5c49ab487154074eaab2ef80e9a2f8163320c (diff)
downloadpatches-6b7b3ca9813d00b734d1318e40e6c10d17859d12.tar
patches-6b7b3ca9813d00b734d1318e40e6c10d17859d12.tar.gz
guix: git: Add new module.
* guix/git.scm: New file. * configure.ac: Check for (guile git). * Makefile.am: Build guix/git.scm if (guile git) is available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dc3d8f377f..c937e948d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,6 +104,10 @@ dnl Guile-JSON is used in various places.
GUILE_MODULE_AVAILABLE([have_guile_json], [(json)])
AM_CONDITIONAL([HAVE_GUILE_JSON], [test "x$have_guile_json" = "xyes"])
+dnl Check for Guile-Git.
+GUILE_MODULE_AVAILABLE([have_guile_git], [(git)])
+AM_CONDITIONAL([HAVE_GUILE_GIT], [test "x$have_guile_git" = "xyes"])
+
dnl Make sure we have a full-fledged Guile.
GUIX_ASSERT_GUILE_FEATURES([regex posix socket net-db threads])