summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-12 00:37:33 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-12 00:40:15 +0100
commit1dbe3a8db0a3e5a8e5f9b30e6f6a6bbfb699275b (patch)
tree1eb49e4166a7affad076771bd5a629c2be065356 /configure.ac
parent5a717a95b33d72026085c2309a2079956586c098 (diff)
downloadpatches-1dbe3a8db0a3e5a8e5f9b30e6f6a6bbfb699275b.tar
patches-1dbe3a8db0a3e5a8e5f9b30e6f6a6bbfb699275b.tar.gz
build: GnuTLS is now a hard dependency.
Discussed as part of <https://bugs.gnu.org/25975>. * configure.ac: Check for (gnutls) and error out if it's missing. * doc/guix.texi (Requirements): Move GnuTLS from optional to required. (Substitutes): Remove footnote about the need for GnuTLS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 06b0618b43..e5daadb121 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,7 +91,14 @@ dnl Installation directory for .scm and .go files.
guilemoduledir="${datarootdir}/guile/site/$GUILE_EFFECTIVE_VERSION"
AC_SUBST([guilemoduledir])
-dnl guile-json is used for the PyPI package importer
+dnl The GnuTLS bindings are necessary for substitutes over HTTPS and for 'guix
+dnl pull', among other things.
+GUILE_MODULE_AVAILABLE([have_gnutls], [(gnutls)])
+if test "x$have_gnutls" != "xyes"; then
+ AC_MSG_ERROR([The Guile bindings of GnuTLS are missing; please install them.])
+fi
+
+dnl Guile-JSON is used in various places.
GUILE_MODULE_AVAILABLE([have_guile_json], [(json)])
AM_CONDITIONAL([HAVE_GUILE_JSON], [test "x$have_guile_json" = "xyes"])