summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-06-25 20:53:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-02-20 12:58:07 +0200
commit3b88f3767d9f3ad2cc64173525cd53d429bfe7e7 (patch)
tree7a928b9e808596c635fab302af5ae9f4c78a6617 /build-aux
parent77e16733197b8950f6b665be1f69375cb2a7155f (diff)
downloadpatches-3b88f3767d9f3ad2cc64173525cd53d429bfe7e7.tar
patches-3b88f3767d9f3ad2cc64173525cd53d429bfe7e7.tar.gz
gnu: Add bootstrap-binaries for 'aarch64-linux'.
These bootstrap-binaries were built against commit 8f8f250bdca917b3ce38aa0902f01b19081859a4. * gnu/packages/bootstrap/aarch64-linux/bash, gnu/packages/bootstrap/aarch64-linux/mkdir, gnu/packages/bootstrap/aarch64-linux/xz, gnu/packages/bootstrap/aarch64-linux/tar: New files. * gnu/local.mk (bootstrap_aarch64_linuxdir) (dist_bootstrap_aarch64_linux_DATA) (nodist_bootstrap_aarch64_linux_DATA): New variables. (DISTCLEANFILES): Add $(nodist_bootstrap_aarch64_linux_DATA). (gnu/packages/bootstrap/aarch64-linux/guile-2.0.14.tar.xz): New target. * build-aux/download.scm (filename->uri): Add aarch64-linux entry. * gnu/packages/bootstrap.scm (raw-build): Use guile-2.0.14.tar.xz on aarch64-linux. (glibc-dynamic-linker, %bootstrap-coreutils&co, %boostrap-binutils) (%bootstrap-glibc, %bootstrap-gcc): Add aarch64-linux cases. * m4/guix.m4 (GUIX_SYSTEM_TYPE): Add aarch64 case. (GUIX_ASSERT_SUPPORTED_SYSTEM): Add aarch64-linux to supported list. * doc/guix.texi (GNU Distribution): Add aarch64-linux to the list of supported systems. * tests/packages.scm (package-search-derivation, snippet): Add aarch64 case.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/download.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/build-aux/download.scm b/build-aux/download.scm
index 1e91e4b87c..e0b40e6f26 100644
--- a/build-aux/download.scm
+++ b/build-aux/download.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,13 +46,18 @@
"Return the URI for FILE."
(match (string-tokenize file (char-set-complement (char-set #\/)))
((_ ... system basename)
- (string->uri (string-append %url-base "/" system
- (match system
- ("armhf-linux"
- "/20150101/")
- (_
- "/20131110/"))
- basename)))))
+ (string->uri
+ (match system
+ ("aarch64-linux"
+ (string-append "http://flashner.co.il/guix/bootstrap/aarch64-linux"
+ "/20170217/" basename))
+ (_ (string-append %url-base "/" system
+ (match system
+ ("armhf-linux"
+ "/20150101/")
+ (_
+ "/20131110/"))
+ basename)))))))
(match (command-line)
((_ file expected-hash)