summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-04-17 18:09:43 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-17 18:09:43 +0200
commit0e993428ce5ebd34d3bd9cb200140ffb2a5ef232 (patch)
treeb40c62ea1c1d5c69d884d0af6e253fc1d17dacf9 /build-aux
parentf50d2669e3e624365221cc81918ba55fdce94107 (diff)
downloadpatches-0e993428ce5ebd34d3bd9cb200140ffb2a5ef232.tar
patches-0e993428ce5ebd34d3bd9cb200140ffb2a5ef232.tar.gz
build: Add `sync-synopses.scm'.
* build-aux/sync-synopses.scm: New file. * Makefile.am (EXTRA_DIST): Add it. (dist-hook): New target.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/sync-synopses.scm61
1 files changed, 61 insertions, 0 deletions
diff --git a/build-aux/sync-synopses.scm b/build-aux/sync-synopses.scm
new file mode 100644
index 0000000000..9aaff11ce0
--- /dev/null
+++ b/build-aux/sync-synopses.scm
@@ -0,0 +1,61 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+;;;
+;;; Report synopses that defer from those found in the GNU Womb.
+;;;
+
+(use-modules (guix gnu-maintenance)
+ (guix packages)
+ (guix utils)
+ (guix ui)
+ (gnu packages)
+ (srfi srfi-1)
+ (srfi srfi-26)
+ (ice-9 match))
+
+(define official
+ ;; GNU package descriptors from the Womb.
+ (official-gnu-packages))
+
+(define gnus
+ ;; GNU packages available in the distro.
+ (let ((lookup (lambda (p)
+ (find (lambda (descriptor)
+ (equal? (gnu-package-name descriptor)
+ (package-name p)))
+ official))))
+ (fold-packages (lambda (package result)
+ (or (and=> (lookup package)
+ (cut alist-cons package <> result))
+ result))
+ '())))
+
+;; Iterate over GNU packages. Report those whose synopsis defers from that
+;; found upstream.
+(for-each (match-lambda
+ ((package . descriptor)
+ (let ((upstream (gnu-package-doc-summary descriptor))
+ (downstream (package-synopsis package))
+ (loc (package-location package)))
+ (unless (and upstream (string=? upstream downstream))
+ (format (guix-warning-port)
+ "~a: ~a: proposed synopsis: ~s~%"
+ (location->string loc) (package-name package)
+ upstream)))))
+ gnus)