summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-31 04:23:12 -0500
committerMark H Weaver <mhw@netris.org>2015-01-07 21:47:51 -0500
commitaa1e19477b2d78884fc500fef497cd6677604d9b (patch)
tree635d061c2a0ff061d241266c9a364ee579826192 /build-aux
parentb58b7dbb75208f92c5eda7834fb42a196d66ca12 (diff)
downloadpatches-aa1e19477b2d78884fc500fef497cd6677604d9b.tar
patches-aa1e19477b2d78884fc500fef497cd6677604d9b.tar.gz
gnu: Add bootstrap binaries for 'armhf-linux'.
* gnu/packages/bootstrap/armhf-linux/bash, gnu/packages/bootstrap/armhf-linux/mkdir, gnu/packages/bootstrap/armhf-linux/tar, gnu/packages/bootstrap/armhf-linux/xz: New files. * gnu-system.am (bootstrap_armhf_linuxdir, dist_bootstrap_armhf_linux_DATA) (nodist_bootstrap_armhf_linux_DATA): New variables. (DISTCLEANFILES): Add $(nodist_bootstrap_armhf_linux_DATA). (gnu/packages/bootstrap/armhf-linux/guile-2.0.11.tar.xz): New target. * build-aux/download.scm (file-name->uri): Use newer date in URI for armhf-linux. * gnu/packages/bootstrap.scm (raw-build): Use "guile-2.0.11.tar.xz" on armhf-linux. (glibc-dynamic-linker, %bootstrap-coreutils&co, %bootstrap-binutils) (%bootstrap-glibc, %bootstrap-gcc): Add armhf-linux cases. * m4/guix.m4 (GUIX_SYSTEM_TYPE): Add armhf case. (GUIX_ASSERT_SUPPORTED_SYSTEM): Add armhf-linux to list of supported systems. * doc/guix.texi (GNU Distribution): Add armhf-linux to the list of supported systems.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/download.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/build-aux/download.scm b/build-aux/download.scm
index 50123f59d2..a107a887dc 100644
--- a/build-aux/download.scm
+++ b/build-aux/download.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,7 +46,12 @@
(match (string-tokenize file (char-set-complement (char-set #\/)))
((_ ... system basename)
(string->uri (string-append %url-base "/" system
- "/20131110/" basename)))))
+ (match system
+ ("armhf-linux"
+ "/20150101/")
+ (_
+ "/20131110/"))
+ basename)))))
(match (command-line)
((_ file expected-hash)