summaryrefslogtreecommitdiff
path: root/build-aux/sync-synopses.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-09 16:13:02 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-09 16:13:02 +0200
commit668d48a6847bcdc69d2c6e6aa44090f566ecd05b (patch)
tree1424220290e4dc8fc4d9dab889ef8b57bf688992 /build-aux/sync-synopses.scm
parent129f9e1173494541687be667d41a7223dc3b1b8a (diff)
downloadpatches-668d48a6847bcdc69d2c6e6aa44090f566ecd05b.tar
patches-668d48a6847bcdc69d2c6e6aa44090f566ecd05b.tar.gz
build: 'sync-descriptions' now compares GNU package descriptions.
* build-aux/sync-synopses.scm: Rename to... * build-aux/sync-descriptions.scm: ... this. Compare the value of 'gnu-package-doc-description' and 'package-description' and report any mismatch. * Makefile.am (EXTRA_DIST): Adjust accordingly. (sync-synopses): Rename to... (sync-descriptions): ... this.
Diffstat (limited to 'build-aux/sync-synopses.scm')
-rw-r--r--build-aux/sync-synopses.scm62
1 files changed, 0 insertions, 62 deletions
diff --git a/build-aux/sync-synopses.scm b/build-aux/sync-synopses.scm
deleted file mode 100644
index c1049d3398..0000000000
--- a/build-aux/sync-synopses.scm
+++ /dev/null
@@ -1,62 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-;;;
-;;; Report synopses that defer from those found in the GNU Womb.
-;;;
-
-(use-modules (guix gnu-maintenance)
- (guix packages)
- (guix utils)
- (guix ui)
- (gnu packages)
- (srfi srfi-1)
- (srfi srfi-26)
- (ice-9 match))
-
-(define official
- ;; GNU package descriptors from the Womb.
- (official-gnu-packages))
-
-(define gnus
- ;; GNU packages available in the distro.
- (let ((lookup (lambda (p)
- (find (lambda (descriptor)
- (equal? (gnu-package-name descriptor)
- (package-name p)))
- official))))
- (fold-packages (lambda (package result)
- (or (and=> (lookup package)
- (cut alist-cons package <> result))
- result))
- '())))
-
-;; Iterate over GNU packages. Report those whose synopsis defers from that
-;; found upstream.
-(for-each (match-lambda
- ((package . descriptor)
- (let ((upstream (gnu-package-doc-summary descriptor))
- (downstream (package-synopsis package))
- (loc (or (package-field-location package 'synopsis)
- (package-location package))))
- (unless (and upstream (string=? upstream downstream))
- (format (guix-warning-port)
- "~a: ~a: proposed synopsis: ~s~%"
- (location->string loc) (package-name package)
- upstream)))))
- gnus)