summaryrefslogtreecommitdiff
path: root/build-aux/download.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2013-10-17 15:47:56 -0400
committerMark H Weaver <mhw@netris.org>2013-11-03 23:26:53 -0500
commitf57ff219ad9e08427e06d9c95fb71cc0764564c2 (patch)
tree98fff85d04ba20d29c48e685fb6bb79b85087b7f /build-aux/download.scm
parentc5916538fdf57c93dc8a5880c9eb4e2ca88aa760 (diff)
downloadpatches-f57ff219ad9e08427e06d9c95fb71cc0764564c2.tar
patches-f57ff219ad9e08427e06d9c95fb71cc0764564c2.tar.gz
gnu: add bootstrap support for mips64el-linux using the MIPS N32 ABI.
* .gitignore: Add entry for bootstrap/mips64el-linux/guile-2.0.9.tar.xz. * gnu-system.am (bootstrap_mips64el_linuxdir, dist_bootstrap_mips64el_linux_DATA, nodist_bootstrap_mips64el_linux_DATA): New variables. (DISTCLEANFILES): Add $(nodist_bootstrap_mips64el_linux_DATA). (gnu/packages/bootstrap/mips64el-linux/guile-2.0.9.tar.xz): New target. * build-aux/download.scm (file-name->uri): Adapt to the newer mips64el-linux bootstrap tarballs. * gnu/packages/bootstrap.scm (%bootstrap-guile, %bootstrap-coreutils&co, %bootstrap-binutils, %bootstrap-glibc, %bootstrap-gcc): Adapt to the newer mips64el-linux bootstrap tarballs. * gnu/packages/bootstrap/mips64el-linux/bash: * gnu/packages/bootstrap/mips64el-linux/mkdir: * gnu/packages/bootstrap/mips64el-linux/tar: * gnu/packages/bootstrap/mips64el-linux/xz: New files.
Diffstat (limited to 'build-aux/download.scm')
-rw-r--r--build-aux/download.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/build-aux/download.scm b/build-aux/download.scm
index 91b41bcec1..68ad7773f5 100644
--- a/build-aux/download.scm
+++ b/build-aux/download.scm
@@ -45,7 +45,12 @@
(match (string-tokenize file (char-set-complement (char-set #\/)))
((_ ... system basename)
(string->uri (string-append %url-base "/" system
- "/20130105/" basename)))))
+ (match system
+ ("mips64el-linux"
+ "/20131017/")
+ (_
+ "/20130105/"))
+ basename)))))
(match (command-line)
((_ file expected-hash)