summaryrefslogtreecommitdiff
path: root/build-aux/compile-all.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-14 09:57:21 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-14 10:28:57 +0100
commitae196fa3490733ee43fccc57acb0194d640273cd (patch)
tree6c3cb33ecebba04f362edd88d3d11809e903964e /build-aux/compile-all.scm
parenta70782d37b29c1af0cff5829027a242eaaa4453e (diff)
downloadpatches-ae196fa3490733ee43fccc57acb0194d640273cd.tar
patches-ae196fa3490733ee43fccc57acb0194d640273cd.tar.gz
build: On 2.2, build package files with almost no optimizations.
* build-aux/compile-all.scm (%default-optimizations) (%lightweight-optimizations): New variables. (optimization-options): New procedure. (compile-file*): Use it.
Diffstat (limited to 'build-aux/compile-all.scm')
-rw-r--r--build-aux/compile-all.scm33
1 files changed, 31 insertions, 2 deletions
diff --git a/build-aux/compile-all.scm b/build-aux/compile-all.scm
index 6ce4040887..d077d75229 100644
--- a/build-aux/compile-all.scm
+++ b/build-aux/compile-all.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -63,6 +63,34 @@
(format #t " LOAD ~a~%" module)
(resolve-interface module)))
+(cond-expand
+ (guile-2.2 (use-modules (language tree-il optimize)
+ (language cps optimize)))
+ (else #f))
+
+(define %default-optimizations
+ ;; Default optimization options (equivalent to -O2 on Guile 2.2).
+ (cond-expand
+ (guile-2.2 (append (tree-il-default-optimization-options)
+ (cps-default-optimization-options)))
+ (else '())))
+
+(define %lightweight-optimizations
+ ;; Lightweight optimizations (like -O0, but with partial evaluation).
+ (let loop ((opts %default-optimizations)
+ (result '()))
+ (match opts
+ (() (reverse result))
+ ((#:partial-eval? _ rest ...)
+ (loop rest `(#t #:partial-eval? ,@result)))
+ ((kw _ rest ...)
+ (loop rest `(#f ,kw ,@result))))))
+
+(define (optimization-options file)
+ (if (string-contains file "gnu/packages/")
+ %lightweight-optimizations ;build faster
+ '()))
+
(define (compile-file* file output-mutex)
(let ((go (scm->go file)))
(with-mutex output-mutex
@@ -74,7 +102,8 @@
(lambda ()
(compile-file file
#:output-file go
- #:opts `(#:warnings ,warnings)))))))
+ #:opts `(#:warnings ,warnings
+ ,@(optimization-options file))))))))
;; Install a SIGINT handler to give unwind handlers in 'compile-file' an
;; opportunity to run upon SIGINT and to remove temporary output files.