summaryrefslogtreecommitdiff
path: root/bootstrap
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-03 22:43:26 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-03 23:05:11 +0100
commitb49ffe2d678b5df4192fb9be4ad50bed9d6d5b7f (patch)
treeaabab3a816f2e5a98838d5ddcc9d37cab7d0cdac /bootstrap
parente05385192ca201d44d607af162f197ad39fd1987 (diff)
downloadpatches-b49ffe2d678b5df4192fb9be4ad50bed9d6d5b7f.tar
patches-b49ffe2d678b5df4192fb9be4ad50bed9d6d5b7f.tar.gz
build: Add `bootstrap' and `sync-with-upstream' scripts.
* bootstrap, nix/sync-with-upstream: New files. * Makefile.am (EXTRA_DIST): Add `bootstrap'. * daemon.am (EXTRA_DIST): Add `nix/sync-with-upstream'.
Diffstat (limited to 'bootstrap')
-rwxr-xr-xbootstrap16
1 files changed, 16 insertions, 0 deletions
diff --git a/bootstrap b/bootstrap
new file mode 100755
index 0000000000..e445af2f2c
--- /dev/null
+++ b/bootstrap
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+# Import missing source files and create the build system.
+
+set -e -x
+
+top_srcdir="$PWD"
+export top_srcdir
+
+if [ ! -d nix-upstream ]
+then
+ git submodule init
+fi
+git submodule update
+
+exec autoreconf -vfi