summaryrefslogtreecommitdiff
path: root/bootstrap
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-08 14:35:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-18 11:38:14 +0200
commit7bc46ecc34ceb042ff890e5d306d0a2a736e891d (patch)
tree9f5952d815edc41bae127e101ee1781ed1eb809a /bootstrap
parenta870b80046d532329762095683d8f9c33538eaf1 (diff)
downloadpatches-7bc46ecc34ceb042ff890e5d306d0a2a736e891d.tar
patches-7bc46ecc34ceb042ff890e5d306d0a2a736e891d.tar.gz
doc: Add Guix Cookbook.
* .gitignore: Update ignore list. * Makefile.am (assert-no-store-file-names): Exclude the cookbook. * bootstrap: Generate po files for cookbook translations. * doc/guix-cookbook.texi: New file. * doc/local.mk (info_TEXINFOS): Add it; add a rule to build cookbook translations. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): New variable. (EXTRA_DIST): Add cookbook pot file and po files. (doc-po-update-cookbook-%): New target. (doc-pot-update): Also update cookbook pot file. (doc-po-update): Also update cookbook po files.
Diffstat (limited to 'bootstrap')
-rwxr-xr-xbootstrap12
1 files changed, 11 insertions, 1 deletions
diff --git a/bootstrap b/bootstrap
index c0b5af7677..c9e7a084a1 100755
--- a/bootstrap
+++ b/bootstrap
@@ -4,7 +4,7 @@
set -e -x
# Generate stubs for translations.
-langs=`find po/doc -type f -name '*.po' \
+langs=`find po/doc -type f -name 'guix-manual*.po' \
| sed -e 's,guix-manual\.,,' \
| xargs -n 1 -I{} basename {} .po`
for lang in ${langs}; do
@@ -15,5 +15,15 @@ for lang in ${langs}; do
touch "po/doc/guix-manual.${lang}.po"
fi
done
+langs=`find po/doc -type f -name 'guix-cookbook*.po' \
+ | sed -e 's,guix-manual\.,,' \
+ | xargs -n 1 -I{} basename {} .po`
+for lang in ${langs}; do
+ if [ ! -e "doc/guix-cookbook.${lang}.texi" ]; then
+ echo "@setfilename guix-cookbook.${lang}.info" > "doc/guix-cookbook.${lang}.texi"
+ # Ensure .po file is newer.
+ touch "po/doc/guix-cookbook.${lang}.po"
+ fi
+done
exec autoreconf -vfi