summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-01-24 18:48:29 +0100
committerMathieu Lirzin <mthl@gnu.org>2016-01-28 16:31:38 +0100
commit8c3d8894562ac990e7b5f23e74e6f12ea14b1a87 (patch)
treeaa07b8cfe3a6c1b8e900ece4b2d4984955b5c660 /Makefile.am
parent74e667d14912b9243043b43995848d962569a9a1 (diff)
downloadpatches-8c3d8894562ac990e7b5f23e74e6f12ea14b1a87.tar
patches-8c3d8894562ac990e7b5f23e74e6f12ea14b1a87.tar.gz
build: Add 'DL' silent rule.
* Makefile.am (AM_V_DL, AM_V_DL_, AM_V_DL_0): New variables. * gnu-system.am (gnu/packages/bootstrap/x86_64-linux/guile-2.0.9.tar.xz) (gnu/packages/bootstrap/i686-linux/guile-2.0.9.tar.xz) (gnu/packages/bootstrap/armhf-linux/guile-2.0.11.tar.xz) (gnu/packages/bootstrap/mips64el-linux/guile-2.0.9.tar.xz): Use $(AM_V_DL). * build-aux/download.scm: Print a line break between target and origin.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1ede6d4057..4e97ff18d7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,7 @@
# Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2013 Andreas Enge <andreas@enge.fr>
# Copyright © 2015 Alex Kost <alezost@gmail.com>
+# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
#
# This file is part of GNU Guix.
#
@@ -471,3 +472,11 @@ assert-final-inputs-self-contained:
.PHONY: sync-descriptions gen-ChangeLog gen-AUTHORS clean-go make-go
.PHONY: assert-no-store-file-names assert-binaries-available
.PHONY: assert-final-inputs-self-contained
+
+## -------------- ##
+## Silent rules. ##
+## -------------- ##
+
+AM_V_DL = $(AM_V_DL_$(V))
+AM_V_DL_ = $(AM_V_DL_$(AM_DEFAULT_VERBOSITY))
+AM_V_DL_0 = @echo " DL " $@;