summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-01-24 19:04:53 +0100
committerMathieu Lirzin <mthl@gnu.org>2016-01-28 16:31:38 +0100
commite71ad29ddbb4ad8f3e986681fbe746847c4ca723 (patch)
treeffc1dd9b383a0c798a3e3a7d2976af3f1b93d8af /Makefile.am
parent54523748354bb5144a9a9102fbcfabed49b71e73 (diff)
downloadpatches-e71ad29ddbb4ad8f3e986681fbe746847c4ca723.tar
patches-e71ad29ddbb4ad8f3e986681fbe746847c4ca723.tar.gz
build: Use 'GEN' and 'at' silent rules.
* daemon.am (nix/libstore/schema.sql.hh, etc/guix-daemon.service) (etc/guix-daemon.conf): Use $(AM_V_GEN). * doc.am (doc/os-config-%.texi, .png.eps): Likewise. * Makefile.am (guix-binary.%.tar.xz, gen-ChangeLog, gen-AUTHORS): Likewise. (assert-binaries-available, assert-final-inputs-self-contained) (assert-no-store-file-names, sync-descriptions): Use $(AM_V_at).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index bc015e23e3..6784da014b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -420,7 +420,7 @@ include emacs.am
# The self-contained tarball.
guix-binary.%.tar.xz:
- -GUIX_PACKAGE_PATH= \
+ $(AM_V_GEN)GUIX_PACKAGE_PATH= \
$(top_builddir)/pre-inst-env "$(GUILE)" \
"$(top_srcdir)/build-aux/make-binary-tarball.scm" "$*" "$@"
@@ -431,11 +431,11 @@ dist-hook: assert-no-store-file-names
distcheck-hook: assert-binaries-available assert-final-inputs-self-contained
sync-descriptions:
- -GUIX_PACKAGE_PATH= \
+ $(AM_V_at)GUIX_PACKAGE_PATH= \
$(top_builddir)/pre-inst-env guix lint --checkers=gnu-description
gen-ChangeLog:
- if test -d .git; then \
+ $(AM_V_GEN)if test -d .git; then \
$(top_srcdir)/build-aux/gitlog-to-changelog \
> $(distdir)/cl-t; \
rm -f $(distdir)/ChangeLog; \
@@ -443,7 +443,7 @@ gen-ChangeLog:
fi
gen-AUTHORS:
- if test -d .git; then \
+ $(AM_V_GEN)if test -d .git; then \
rm -f "$(distdir)/AUTHORS"; \
$(top_builddir)/pre-inst-env "$(GUILE)" \
"$(top_srcdir)/build-aux/generate-authors.scm" \
@@ -452,7 +452,7 @@ gen-AUTHORS:
# Make sure we're not shipping a file that embeds a local /gnu/store file name.
assert-no-store-file-names:
- if grep -r --exclude=*.texi --exclude=*.info \
+ $(AM_V_at)if grep -r --exclude=*.texi --exclude=*.info \
"$(storedir)/[a-z0-9]{32}-" $(distdir) ; \
then \
echo "error: store file names embedded in the distribution" >&2 ; \
@@ -461,12 +461,12 @@ assert-no-store-file-names:
# Make sure hydra.gnu.org has the important binaries.
assert-binaries-available:
- $(top_builddir)/pre-inst-env "$(GUILE)" \
+ $(AM_V_at)$(top_builddir)/pre-inst-env "$(GUILE)" \
"$(top_srcdir)/build-aux/check-available-binaries.scm"
# Make sure the final inputs don't refer to bootstrap tools.
assert-final-inputs-self-contained:
- $(top_builddir)/pre-inst-env "$(GUILE)" \
+ $(AM_V_at)$(top_builddir)/pre-inst-env "$(GUILE)" \
"$(top_srcdir)/build-aux/check-final-inputs-self-contained.scm"
.PHONY: sync-descriptions gen-ChangeLog gen-AUTHORS clean-go make-go