summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-13 00:33:43 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-13 00:33:43 +0100
commit671d8f5e6f6b9556286f2d58a98d12bcac172299 (patch)
tree10b293cb2e2733644bd9bdc79e383bba35deb1c6 /Makefile.am
parent25608d640a97c64a6e1f493ca3e46d9168866249 (diff)
downloadpatches-671d8f5e6f6b9556286f2d58a98d12bcac172299.tar
patches-671d8f5e6f6b9556286f2d58a98d12bcac172299.tar.gz
build: Add $(top_builddir) to the load path.
* Makefile.am (DOWNLOAD_FILE): Add $(top_builddir) to the search path, since that's where guix/config.scm is. (.scm.go): Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 6c66014738..d48f5dc870 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -124,7 +124,7 @@ DISTCLEANFILES = \
# Method to download a file from an external source.
DOWNLOAD_FILE = \
GUILE_LOAD_COMPILED_PATH="$(top_builddir):$$GUILE_LOAD_COMPILED_PATH" \
- $(GUILE) --no-auto-compile -L "$(top_srcdir)" \
+ $(GUILE) --no-auto-compile -L "$(top_builddir)" -L "$(top_srcdir)" \
"$(top_srcdir)/build-aux/download.scm"
distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz:
@@ -172,12 +172,12 @@ CLEANFILES = $(GOBJECTS) *.log
.scm.go:
$(MKDIR_P) `dirname "$@"`
- DISTRO_INSTALLED_PATCH_DIRECTORY="$(patchdir)" \
- DISTRO_INSTALLED_BOOTSTRAP_DIRECTORY="$(bootstrapdir)" \
- $(top_builddir)/pre-inst-env \
- $(GUILD) compile -L "$(top_srcdir)" \
- -Wformat -Wunbound-variable -Warity-mismatch \
- --target="$(host)" \
+ DISTRO_INSTALLED_PATCH_DIRECTORY="$(patchdir)" \
+ DISTRO_INSTALLED_BOOTSTRAP_DIRECTORY="$(bootstrapdir)" \
+ $(top_builddir)/pre-inst-env \
+ $(GUILD) compile -L "$(top_builddir)" -L "$(top_srcdir)" \
+ -Wformat -Wunbound-variable -Warity-mismatch \
+ --target="$(host)" \
-o "$@" "$<"
SUFFIXES = .go