summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-04-29 21:52:21 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-29 21:52:21 +0200
commit30dd831083339483771d8bcc0bdecd1f447bbcfd (patch)
treeca60312ebdc9eca68cc4a92a5cda581d5a3c0ce8 /Makefile.am
parent8e77f41ede94be3e3a80f0f19810aac954609eb7 (diff)
downloadpatches-30dd831083339483771d8bcc0bdecd1f447bbcfd.tar
patches-30dd831083339483771d8bcc0bdecd1f447bbcfd.tar.gz
build: Replace *.log in `CLEANFILES' by the exact list of files.
* Makefile.am (SCM_TESTS, SH_TESTS): New variables. (TESTS): Use them. (CLEANFILES): Replace *.log by $(SCM_TESTS:%.scm=%.log).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 907be9e141..ceb6918e79 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -289,7 +289,7 @@ gnu/packages/bootstrap/i686-linux/guile-2.0.7.tar.xz:
nobase_nodist_guilemodule_DATA = $(GOBJECTS) guix/config.scm
-TESTS = \
+SCM_TESTS = \
tests/base32.scm \
tests/builders.scm \
tests/derivations.scm \
@@ -300,12 +300,16 @@ TESTS = \
tests/snix.scm \
tests/store.scm \
tests/nar.scm \
- tests/union.scm \
+ tests/union.scm
+
+SH_TESTS = \
tests/guix-build.sh \
tests/guix-download.sh \
tests/guix-gc.sh \
tests/guix-package.sh
+TESTS = $(SCM_TESTS) $(SH_TESTS)
+
TEST_EXTENSIONS = .scm .sh
AM_TESTS_ENVIRONMENT = abs_top_srcdir="$(abs_top_srcdir)"
@@ -332,7 +336,9 @@ EXTRA_DIST = \
release.nix \
$(TESTS)
-CLEANFILES = $(GOBJECTS) *.log
+CLEANFILES = \
+ $(GOBJECTS) \
+ $(SCM_TESTS:%.scm=%.log)
# XXX: Use the C locale for when Guile lacks
# <http://git.sv.gnu.org/cgit/guile.git/commit/?h=stable-2.0&id=e2c6bf3866d1186c60bacfbd4fe5037087ee5e3f>.