aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-05-24 22:12:13 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-24 22:12:13 +0200
commit36747eb0dad504686560afba51742f782f7c3646 (patch)
tree2a35da31146f0a6693fd9cddfc0c514edefe9c99 /Makefile.am
parentffaf5cbd361b6589daac1912aa5a43abea86e52b (diff)
parent0b7b8fb0456475374de24b6302a6ce3cc5921ed0 (diff)
downloadpatches-36747eb0dad504686560afba51742f782f7c3646.tar
patches-36747eb0dad504686560afba51742f782f7c3646.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7c07d1b2b9..c2fc2642a7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -422,6 +422,7 @@ EXTRA_DIST = \
build-aux/generate-authors.scm \
build-aux/test-driver.scm \
build-aux/update-guix-package.scm \
+ build-aux/update-NEWS.scm \
build-aux/run-system-tests.scm \
d3.v3.js \
graph.js \
@@ -666,6 +667,15 @@ update-guix-package:
$(top_srcdir)/build-aux/update-guix-package.scm \
"`git rev-parse HEAD`"
+# Location of a checkout of <git://git.savannah.gnu.org/guix/maintenance.git>.
+# Package data from this checkout is used by 'update-NEWS.scm'.
+GUIX_MAINTENANCE_DIRECTORY ?= $(top_srcdir)/../guix-maintenance
+
+update-NEWS: $(GOBJECTS)
+ $(top_builddir)/pre-inst-env "$(GUILE)" \
+ $(top_srcdir)/build-aux/update-NEWS.scm \
+ $(top_srcdir)/NEWS "$(GUIX_MAINTENANCE_DIRECTORY)/data"
+
# Make sure we're not shipping a file that embeds a local /gnu/store file name.
assert-no-store-file-names: $(distdir)/ChangeLog
$(AM_V_at)if grep -r --exclude=*.texi --exclude=*.info \
@@ -701,7 +711,7 @@ hydra-jobs.scm: $(GOBJECTS)
.PHONY: assert-no-store-file-names assert-binaries-available
.PHONY: assert-final-inputs-self-contained
.PHONY: clean-go make-go
-.PHONY: update-guix-package release
+.PHONY: update-guix-package update-NEWS release
## -------------- ##
## Silent rules. ##