summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-12-05 22:49:51 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-05 22:50:38 +0100
commitde1355f186065c99300b48bea6f12f3b8a8d3230 (patch)
tree4c124fbe21753e87965a17684ac963658d8249db /Makefile.am
parente7de5ac0d56dfc895d5a60d59f6307d6b966346a (diff)
downloadpatches-de1355f186065c99300b48bea6f12f3b8a8d3230.tar
patches-de1355f186065c99300b48bea6f12f3b8a8d3230.tar.gz
build: Work around build problem on systems that lack (gnutls).
Reported at <https://lists.gnu.org/archive/html/guix-devel/2013-12/msg00002.html>. * Makefile.am (MODULES): Shuffle modules to work around build failure on systems that lack the (gnutls) module.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 9462878d1c..a99f8c1a25 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,25 +27,16 @@ nodist_noinst_SCRIPTS = \
include gnu-system.am
MODULES = \
- guix/scripts/build.scm \
- guix/scripts/download.scm \
- guix/scripts/import.scm \
- guix/scripts/package.scm \
- guix/scripts/gc.scm \
- guix/scripts/hash.scm \
- guix/scripts/pull.scm \
- guix/scripts/substitute-binary.scm \
- guix/scripts/refresh.scm \
guix/base32.scm \
guix/records.scm \
guix/hash.scm \
guix/utils.scm \
+ guix/download.scm \
guix/monads.scm \
guix/profiles.scm \
guix/serialization.scm \
guix/nar.scm \
guix/derivations.scm \
- guix/download.scm \
guix/gnu-maintenance.scm \
guix/licenses.scm \
guix/build-system.scm \
@@ -71,12 +62,22 @@ MODULES = \
guix/build/rpath.scm \
guix/packages.scm \
guix/snix.scm \
+ guix/scripts/download.scm \
+ guix/scripts/build.scm \
+ guix/scripts/import.scm \
+ guix/scripts/package.scm \
+ guix/scripts/gc.scm \
+ guix/scripts/hash.scm \
+ guix/scripts/pull.scm \
+ guix/scripts/substitute-binary.scm \
+ guix/scripts/refresh.scm \
guix.scm \
$(GNU_SYSTEM_MODULES)
# Because of the autoload hack in (guix build download), we must build it
# first to avoid errors on systems where (gnutls) is unavailable.
guix/scripts/download.go: guix/build/download.go
+guix/download.go: guix/build/download.go
GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go