summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-07-09 22:17:18 +0200
committerLudovic Courtès <ludo@gnu.org>2013-07-09 22:17:18 +0200
commitc769406010156190c76c435c90d5f08ae56c2ca4 (patch)
tree1088a364c987cc6e7dc0bea4918cb498b34649b5 /Makefile.am
parentee48b283fadca825ca08500eeb3870fd4141221e (diff)
parent91ef73d4642658829facee25ffdc91a48d6ccf73 (diff)
downloadpatches-c769406010156190c76c435c90d5f08ae56c2ca4.tar
patches-c769406010156190c76c435c90d5f08ae56c2ca4.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 25 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9d872313e7..189b637be3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,7 +60,6 @@ MODULES = \
guix/build/download.scm \
guix/build/cmake-build-system.scm \
guix/build/gnu-build-system.scm \
- guix/build/gnu-cross-build.scm \
guix/build/perl-build-system.scm \
guix/build/python-build-system.scm \
guix/build/utils.scm \
@@ -172,7 +171,31 @@ $(guix_install_go_files): install-nobase_dist_guilemoduleDATA
SUBDIRS = po
info_TEXINFOS = doc/guix.texi
-EXTRA_DIST += doc/fdl-1.3.texi
+EXTRA_DIST += \
+ doc/fdl-1.3.texi \
+ doc/images/bootstrap-graph.dot \
+ doc/images/bootstrap-graph.eps
+
+infoimagedir = $(infodir)/images
+dist_infoimage_DATA = doc/images/bootstrap-graph.png
+
+# Try hard to obtain an image size and aspect that's reasonable for inclusion
+# in an Info or PDF document.
+DOT_OPTIONS = \
+ -Tpng -Gratio=.9 -Gnodesep=.005 -Granksep=.00005 \
+ -Nfontsize=9 -Nheight=.1 -Nwidth=.1
+
+.dot.png:
+ dot -Tpng $(DOT_OPTIONS) < "$<" > "$@.tmp"
+ mv "$@.tmp" "$@"
+
+.dot.eps:
+ dot -Teps $(DOT_OPTIONS) < "$<" > "$@.tmp"
+ mv "$@.tmp" "$@"
+
+doc/guix.pdf: doc/images/bootstrap-graph.png
+doc/guix.info: doc/images/bootstrap-graph.png
+doc/guix.ps: doc/images/bootstrap-graph.eps
if BUILD_DAEMON