aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-19 18:12:34 -0400
committerMark H Weaver <mhw@netris.org>2015-07-19 18:12:34 -0400
commit1b4e48d498a96d478baa1aae7d9c7ecdbd817d6f (patch)
tree4b650999e49a6f4d3dd116fab3f9ee8222247e07 /Makefile.am
parentaa27987f71cb8afa698ede551e20b1248f160113 (diff)
parent50c7a1e297bff0935674b4f30e854a8889becfdd (diff)
downloadpatches-1b4e48d498a96d478baa1aae7d9c7ecdbd817d6f.tar
patches-1b4e48d498a96d478baa1aae7d9c7ecdbd817d6f.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 5cf9314014..ada4cbea0b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -279,6 +279,7 @@ EXTRA_DIST = \
build-aux/check-final-inputs-self-contained.scm \
build-aux/download.scm \
build-aux/make-binary-tarball.scm \
+ build-aux/generate-authors.scm \
srfi/srfi-37.scm.in \
srfi/srfi-64.scm \
srfi/srfi-64.upstream.scm \
@@ -389,9 +390,12 @@ gen-ChangeLog:
fi
gen-AUTHORS:
- $(top_builddir)/pre-inst-env "$(GUILE)" \
- "$(top_srcdir)/build-aux/generate-authors.scm" \
- "$(top_srcdir)" "$(distdir)/AUTHORS"
+ if test -d .git; then \
+ rm -f "$(distdir)/AUTHORS"; \
+ $(top_builddir)/pre-inst-env "$(GUILE)" \
+ "$(top_srcdir)/build-aux/generate-authors.scm" \
+ "$(top_srcdir)" "$(distdir)/AUTHORS"; \
+ fi
# Make sure we're not shipping a file that embeds a local /gnu/store file name.
assert-no-store-file-names: