summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-03 21:11:02 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-03 21:11:26 +0100
commite76bdf8b87920b87a2a2e728c2e40ff24ca39ffe (patch)
treeffcb4e08f2d00acaf670c8344e6a12da6ea39772 /Makefile.am
parent81dbd783bd9afabd1d8720c9b60a6a93492bb581 (diff)
downloadpatches-e76bdf8b87920b87a2a2e728c2e40ff24ca39ffe.tar
patches-e76bdf8b87920b87a2a2e728c2e40ff24ca39ffe.tar.gz
build: Clearly mark Nixpkgs as optional.
* configure.ac: Always show the result of checking for Nixpkgs. Don't warn when Nixpkgs is not found. * Makefile.am (AM_DISTCHECK_CONFIGURE_FLAGS): Remove `--with-nixpkgs' flag. * guix/utils.scm (%nixpkgs-directory): Use either the compile-time or the run-time `NIXPKGS' environment variable. * release.nix (jobs.tarball, jobs.build): Remove `--with-nixpkgs' configure flag. * README: Mark Nixpkgs as optional. * distro/packages/databases.scm, distro/packages/guile.scm, distro/packages/typesetting.scm: Change uses of `nixpkgs-derivation*' to `nixpkgs-derivation', to avoid failing at compile-time.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8a564624b9..0621cb8c00 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -171,5 +171,5 @@ info_TEXINFOS = doc/guix.texi
EXTRA_DIST += doc/fdl-1.3.texi
ACLOCAL_AMFLAGS = -I m4
-AM_DISTCHECK_CONFIGURE_FLAGS = \
- --with-nixpkgs=$(NIXPKGS) --with-nix-prefix="$(NIX_PREFIX)"
+AM_DISTCHECK_CONFIGURE_FLAGS = \
+ --with-nix-prefix="$(NIX_PREFIX)"