summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-08-17 10:41:27 +0200
committerLudovic Courtès <ludo@gnu.org>2012-08-17 10:41:27 +0200
commit3a310cc017c4bffbee8a6f37569145a593ac2912 (patch)
tree6b12926e76b238bd26a5aa4d9e3f2a444c799517 /Makefile.am
parent93a0a8b3fdced4afe3ac2fb0783944c5d76cb360 (diff)
downloadpatches-3a310cc017c4bffbee8a6f37569145a593ac2912.tar
patches-3a310cc017c4bffbee8a6f37569145a593ac2912.tar.gz
build: Add `--with-libgcrypt-prefix'; capture the path to libgcrypt.
* configure.ac: Add `--with-libgcrypt-prefix'. Substitute `LIBGCRYPT'. * Makefile.am (.scm.go): Pass $(LIBGCRYPT). * guix/utils.scm (%libgcrypt): New variable. (sha256): Use it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 18ebd658e0..b6203eff70 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,6 +75,7 @@ CLEANFILES = $(GOBJECTS) *.log
$(MKDIR_P) `dirname "$@"`
NIX_INSTANTIATE="$(NIX_INSTANTIATE)" \
NIXPKGS="$(NIXPKGS)" \
+ LIBGCRYPT="$(LIBGCRYPT)" \
GUILE_AUTO_COMPILE=0 \
GUILE_LOAD_COMPILED_PATH="$(top_builddir):$$GUILE_LOAD_COMPILED_PATH" \
$(GUILD) compile -L "$(top_srcdir)" \