summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-06 00:03:26 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-06 00:07:08 +0100
commit69cfce50dbb2000c5f5d98f0f364fe324004bf99 (patch)
treeceb925ad7fa3f30b88c6074a071a229a31f769eb /Makefile.am
parentb980f0f9fd6f926f2a1130f77bd3cdb70e741429 (diff)
downloadpatches-69cfce50dbb2000c5f5d98f0f364fe324004bf99.tar
patches-69cfce50dbb2000c5f5d98f0f364fe324004bf99.tar.gz
build: Run all the tests against the just-built daemon.
* test-env.in: New file. * configure.ac: Add it to `AC_CONFIG_FILES' and `commands-exec'. * config-daemon.ac: Set and substitute `GUIX_TEST_ROOT'. * Makefile.am (SCM_LOG_COMPILER, SH_LOG_COMPILER): Use it in lieu of `pre-inst-env'. * daemon.am (test_root): Remove (AM_TESTS_ENVIRONMENT): Remove `TEST_ROOT'. (clean-local): Use $(GUIX_TEST_ROOT); make files writable before removing them.guix_test_root * tests/guix-daemon.sh: Remove `NIX_' variable settings; don't launch `guix-daemon'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 101ac1dfdb..bb5dfbe0f9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -181,10 +181,10 @@ TEST_EXTENSIONS = .scm .sh
AM_TESTS_ENVIRONMENT = abs_top_srcdir="$(abs_top_srcdir)"
-SCM_LOG_COMPILER = $(top_builddir)/pre-inst-env $(GUILE)
+SCM_LOG_COMPILER = $(top_builddir)/test-env $(GUILE)
AM_SCM_LOG_FLAGS = --no-auto-compile -L "$(top_srcdir)"
-SH_LOG_COMPILER = $(top_builddir)/pre-inst-env $(SHELL)
+SH_LOG_COMPILER = $(top_builddir)/test-env $(SHELL)
AM_SH_LOG_FLAGS = -x -e
EXTRA_DIST = \