summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-10-27 23:18:08 +0200
committerLudovic Courtès <ludo@gnu.org>2012-10-27 23:18:08 +0200
commit5992f213d79a5fe8568b3029f9397646a34b8871 (patch)
tree6d5f28725e693adb744d4b0d6a76ebb643df2c6d /Makefile.am
parentb8605698b8611f4835ee526a122e432665b07b73 (diff)
downloadpatches-5992f213d79a5fe8568b3029f9397646a34b8871.tar
patches-5992f213d79a5fe8568b3029f9397646a34b8871.tar.gz
build: Preserve the executable bit of bootstrap binaries.
* Makefile.am (install-data-hook): New target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cf3e16bbc6..10f3b61702 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -87,6 +87,11 @@ nodist_bootstrap_x86_64_linux_DATA = \
nodist_bootstrap_i686_linux_DATA = \
distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz
+# Those files must remain executable, so they remain executable once
+# imported into the store.
+install-data-hook:
+ chmod +x $(DESTDIR)$(bootstrapdir)/*/{bash,mkdir,tar,xz}
+
DISTCLEANFILES = \
$(nodist_bootstrap_x86_64_linux_DATA) \
$(nodist_bootstrap_i686_linux_DATA)