summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-20 01:33:29 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-20 01:38:56 +0100
commit0f0995521393b9ec1733de3475bf74c89732e556 (patch)
tree6efed86d019eed85485411410f7befec91015a5f /Makefile.am
parent5d4fd2671aaadc5b0b7e0c331fa5e2a1d7e5c4d8 (diff)
downloadpatches-0f0995521393b9ec1733de3475bf74c89732e556.tar
patches-0f0995521393b9ec1733de3475bf74c89732e556.tar.gz
distro: Update bootstrap binaries.
Use bootstrap binaries that were generated with the `make-bootstrap' changes introduced in previous commit. * Makefile.am (nodist_bootstrap_x86_64_linux_DATA, nodist_bootstrap_i686_linux_DATA): Change Guile tarball name. (distro/packages/bootstrap/x86_64-linux/guile-2.0.7.tar.xz, distro/packages/bootstrap/i686-linux/guile-2.0.7.tar.xz): New targets. (distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz, distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz): Remove. * build-aux/download.scm (file-name->uri): Use "20121219" directory. * distro/packages/bootstrap.scm (%bootstrap-guile): Update file name. (%bootstrap-coreutils&co, %bootstrap-binutils, %bootstrap-glibc, %bootstrap-gcc): Update directory name and hashes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index f256e47995..0f58d09d8b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -142,9 +142,9 @@ dist_bootstrap_i686_linux_DATA = \
# Big bootstrap binaries are not included in the tarball. Instead, they
# are downloaded.
nodist_bootstrap_x86_64_linux_DATA = \
- distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz
+ distro/packages/bootstrap/x86_64-linux/guile-2.0.7.tar.xz
nodist_bootstrap_i686_linux_DATA = \
- distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz
+ distro/packages/bootstrap/i686-linux/guile-2.0.7.tar.xz
# Those files must remain executable, so they remain executable once
# imported into the store.
@@ -161,12 +161,12 @@ DOWNLOAD_FILE = \
$(GUILE) --no-auto-compile -L "$(top_builddir)" -L "$(top_srcdir)" \
"$(top_srcdir)/build-aux/download.scm"
-distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz:
+distro/packages/bootstrap/x86_64-linux/guile-2.0.7.tar.xz:
$(MKDIR_P) `dirname "$@"`
- $(DOWNLOAD_FILE) "$@" "0467a82cbe4136f60a79eb4176011bf88cf28ea19c9ad9defa365811ff8e11cf"
-distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz:
+ $(DOWNLOAD_FILE) "$@" "953fbcc8db6e310626be79b67319cf4141dc23b296447952a99d95425b3a4dc1"
+distro/packages/bootstrap/i686-linux/guile-2.0.7.tar.xz:
$(MKDIR_P) `dirname "$@"`
- $(DOWNLOAD_FILE) "$@" "93b537766dfab3ad287143523751e3ec02dd32d3ccaf88ad2d31c63158f342ee"
+ $(DOWNLOAD_FILE) "$@" "45d1f9bfb9e4531a8f1c5a105f7ab094cd481b8a179ccc63cbabb73ce6b8437f"
nobase_nodist_guilemodule_DATA = $(GOBJECTS) guix/config.scm